php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23055 Make failing: Undefined symbol: .mysql_character_set_name
Submitted: 2003-04-04 10:44 UTC Modified: 2003-04-04 11:20 UTC
From: patrick_cossette1 at uqtr dot ca Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.3.2-RC OS: AIX 4.3.3
Private report: No CVE-ID: None
 [2003-04-04 10:44 UTC] patrick_cossette1 at uqtr dot ca
I'm trying to compile PHP-4.3.1 (I also tried php4-STABLE-200304021830) with the following flags:

./configure
      --prefix=/p/testsphp432/ 
      --with-config-file-path=/p/testsphp432/etc
      --with-mysql=/p/mysql

and I'm getting the following when I run make:

main/internal_functions.lo -lmysqlclient -lcrypt -lm -lcrypt  -o sapi/cgi/php
ld: 0711-317 ERROR: Undefined symbol: .mysql_character_set_name

ld: 0711-317 ERROR: Undefined symbol: .mysql_real_escape_string

ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more information.

make: 1254-004 The error code from the last command is 8.

Stop.



I also tried with the snapshot php4-STABLE-200304021830 and I get the same error.

I also tried setting the following two environment variables                  (which helped me setup php with the past versions) but it did nothing with 4.3.1 and the latest stable (I get the same error message).
      CFLAGS='-qmaxmem=32768 -DInline=ma'
      CC='cc -ma'

Maybe it's a compiler problem or there is a compiler flag missing but I've been trying all sort of things for days and I saw similar problems in the past in the bug history.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-04 10:52 UTC] sniper@php.net
What mysql version?
Does using the bundled mysql work? (ie. using plain --with-mysql)


 [2003-04-04 11:20 UTC] georg@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.


Please update your MySQL Version! Versions < 3.23 aren't supported anymore. Current stable version in 4.0.12
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 03:04:47 2023 UTC