php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22991 PHP mail not being received by hotmail
Submitted: 2003-03-31 14:18 UTC Modified: 2003-03-31 17:16 UTC
From: rcflyer at myself dot com Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.3.2RC1 OS: Liniux
Private report: No CVE-ID: None
 [2003-03-31 14:18 UTC] rcflyer at myself dot com
PHP mail() will not send to hotmail? how come?  

--------------------------------------------------------------------------------
 
Ive tried several hotmail addresses and ive tried several normal ISP addresses and nothing send to hotmail addresses but all messages goto normal addresses, does anyone know how to solve this problem? 

This is the function im using. 

mail( '"' . $emailto . '" <' . $emailto1 . '>', 
$subject, $Body, 
'Return-Path: "' . $From . '" <' . $From1 . ">\n" 
. 'From: "' . $From . '" <' . $From1 . ">\n" 
. 'Reply-To: "' . $From . '" <' . $From1 . ">\n" 
. "MIME-Version: 1.0\n Content-Type: multipart/mixed;\nX-Mailer: PHP/" . phpversion() . "\n" 
. "X-From-IP: " . $REMOTE_ADDR ); 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-31 15:01 UTC] pollita@php.net
Your first problem is that you're attempting to specify realname in the $to parameter of mail().

Don't do that.

The first parameter of mail() should be an email address and ONLY an email address.

That much aside everything you have (From/Return-Path/etc..) should be enough, however, your mail server may be setup to not trust those headers from the user.  Look for a setting of 'trusted-users' or similar in your mail server configuration and make sure your webserver user is listed in there.

All that said, any further comments on this 'bug' should be discussed on general@lists.php.net as this is not a bug, but rather a scripting problem.

P.S. - 'Output Control' is not the correct category for this report either.  This should have been submitted under 'Mail Related'.  I'm changing that now so that our stats are keep consistent.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 00:05:45 2022 UTC