php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22956 COM cannot execute in Windows XP
Submitted: 2003-03-29 20:47 UTC Modified: 2003-03-30 05:51 UTC
From: uk4460 at yahoo dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.1 OS: Windows XP
Private report: No CVE-ID: None
 [2003-03-29 20:47 UTC] uk4460 at yahoo dot com
I have working with COM Object to create a php program like below:
<?php
$word = new com("word.application")  or die("Unable to instanciate Word");
print "Loaded Word, version {$word->Version}\n";
$word->Visible = 1;
$word->Documents->Add();
$word->Selection->TypeText("Testing");
$word->Documents[1]->SaveAs("test.doc");
//$word->Quit();
?>
In windows 98, it can execute and can show the word application, but the same setting in php.ini and so on, it cannot run in Windows XP. It only resident "WINWORD" in memory which i can see through press the Ctrl+Alt+Del, but it don't do anything even make the word application object visible. Why can be happen? Please send the solution to my email - uk4460@yahoo.com if u site can solve this problem. Thanks... a lot





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-29 22:06 UTC] rioter@php.net
this to me seems like the desired results 
as this is not a bug in php im marking it as bogus

 [2003-03-29 23:03 UTC] rioter@php.net
oops 
it doesnt work in 4.3.1 it seems for some reason apache was loading 4.2.2 sorry about that 
open again
 [2003-03-30 04:18 UTC] rioter@php.net
how are you trying to run the script?
as far as i can see ( this is my first look at COM objects) it run as a module of apache but will not become visible however if you run it from the command line it will 

 [2003-03-30 05:51 UTC] phanto@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

how many bugs must a man close down, before you can call him a man ?
hey dudes, BROWSE THE BUGDATABASE BEFORE FILING A NEW ONE !
4.3.0 and 4.3.1 are badly broken.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Feb 03 11:03:46 2023 UTC