php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22943 "Problem with method call" segfault
Submitted: 2003-03-28 17:31 UTC Modified: 2003-03-28 20:25 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: dubious at 2xtreme dot net Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 4.3.2RC1 OS: Linux (2.5.66)
Private report: No CVE-ID: None
 [2003-03-28 17:31 UTC] dubious at 2xtreme dot net
Not sure where to start with this one - I'm getting an 
unexplained segfault while running a script I'm in the middle 
of trying to debug. 
 
The error states "PHP Warning:  Problem with method call - 
please report this bug in 
/root/projects/biophp_code/clustal_parser_class.php on line 
48 
PHP Fatal error:  Call to a member function on a non-object 
in /root/projects/biophp_code/clustal_parser_class.php on 
line 49 
Segmentation fault" 
 
You can find a tarball of the relevant files, plus the output 
from strace, in the tarball at 
http://www.dogphilosophy.net/~biophp/php_clustal_crash.tar.bz2 
 
The script I'm running is "clustal_parser_test.php" 
 
Note I went back and recompiled 4.3.1 and 4.3.0, and both 
also exhibit the same problem... 
 
In case it's helpful, the output from php -i is: 
PHP Version => 4.3.2-RC1 
 
System => Linux enzymestew 2.5.66 #2 Mon Mar 24 
22:58:05 MST 2003 i686 
Build Date => Mar 25 2003 15:20:43 
Configure Command =>  './configure' '--enable-sockets' 
'--with-ncurses' '--with-java=/usr/local/jdk' '--with-gd' 
'--enable-ftp' '--with-mysql' '--with-dom' '--with-zlib' 
'--enable-exif' '--with-bz2' '--with-curl' 
'--with-imap=/tmp/temp/imap-2002' 
'--with-imap-ssl=/tmp/temp/imap-2002' '--disable-cgi' 
Server API => Command Line Interface 
Virtual Directory Support => disabled 
Configuration File (php.ini) Path => /usr/local/lib/php.ini 
PHP API => 20020918 
PHP Extension => 20020429 
Zend Extension => 20021010 
Debug Build => no 
Thread Safety => disabled 
Registered PHP Streams => php, http, ftp, compress.bzip2, 
compress.zlib 
 
 
This program makes use of the Zend Scripting Language 
Engine: 
Zend Engine v1.3.0, Copyright (c) 1998-2003 Zend 
Technologies<br /> 
 
 
_______________________________________________________________________ 
 
 
Configuration 
 
PHP Core 
 
Directive => Local Value => Master Value 
allow_call_time_pass_reference => Off => Off 
allow_url_fopen => On => On 
always_populate_raw_post_data => Off => Off 
arg_separator.input => &amp; => &amp; 
arg_separator.output => &amp; => &amp; 
asp_tags => Off => Off 
auto_append_file => no value => no value 
auto_prepend_file => no value => no value 
browscap => no value => no value 
default_charset => no value => no value 
default_mimetype => text/html => text/html 
define_syslog_variables => Off => Off 
disable_classes => no value => no value 
disable_functions => no value => no value 
display_errors => Off => Off 
display_startup_errors => Off => Off 
doc_root => no value => no value 
docref_ext => no value => no value 
docref_root => http://www.php.net/ => 
http://www.php.net/ 
enable_dl => On => On 
error_append_string => no value => no value 
error_log => no value => no value 
error_prepend_string => no value => no value 
error_reporting => 2047 => 2047 
expose_php => On => On 
extension_dir => ./ => ./ 
file_uploads => On => On 
gpc_order => GPC => GPC 
highlight.bg => #FFFFFF => #FFFFFF 
highlight.comment => #FF9900 => #FF9900 
highlight.default => #0000CC => #0000CC 
highlight.html => #000000 => #000000 
highlight.keyword => #006600 => #006600 
highlight.string => #CC0000 => #CC0000 
html_errors => Off => On 
ignore_repeated_errors => Off => Off 
ignore_repeated_source => Off => Off 
ignore_user_abort => Off => Off 
implicit_flush => On => On 
include_path => .:/usr/local/lib/php => .:/usr/local/lib/php 
log_errors => On => On 
log_errors_max_len => 1024 => 1024 
magic_quotes_gpc => Off => Off 
magic_quotes_runtime => Off => Off 
magic_quotes_sybase => Off => Off 
max_execution_time => 0 => 30 
max_input_time => -1 => -1 
open_basedir => no value => no value 
output_buffering => 4096 => 4096 
output_handler => no value => no value 
post_max_size => 8M => 8M 
precision => 14 => 14 
register_argc_argv => On => On 
register_globals => On => On 
report_memleaks => On => On 
safe_mode => Off => Off 
safe_mode_exec_dir => no value => no value 
safe_mode_gid => Off => Off 
safe_mode_include_dir => no value => no value 
sendmail_from => me@localhost.com => me@localhost.com 
sendmail_path => /usr/sbin/sendmail -t -i  => 
/usr/sbin/sendmail -t -i 
short_open_tag => On => On 
SMTP => localhost => localhost 
smtp_port => 25 => 25 
sql.safe_mode => Off => Off 
track_errors => Off => Off 
unserialize_callback_func => no value => no value 
upload_max_filesize => 2M => 2M 
upload_tmp_dir => no value => no value 
user_dir => no value => no value 
variables_order => GPCS => GPCS 
xmlrpc_error_number => 0 => 0 
xmlrpc_errors => Off => Off 
y2k_compliance => Off => Off 
 
bz2 
 
BZip2 Support => Enabled 
BZip2 Version => 1.0.2, 30-Dec-2001 
 
ctype 
 
ctype functions => enabled 
 
curl 
 
CURL support => enabled 
CURL Information => libcurl/7.10.3 OpenSSL/0.9.6h zlib/1.1.4 
 
domxml 
 
DOM/XML => enabled 
DOM/XML API Version => 20020814 
libxml Version => 20430 
HTML Support => enabled 
XPath Support => enabled 
XPointer Support => enabled 
 
exif 
 
EXIF Support => enabled 
EXIF Version => 1.4 $Id: exif.c,v 1.118.2.13 2002/12/31 
16:34:27 sebastian Exp $ 
Supported EXIF Version => 0220 
Supported filetypes => JPEG,TIFF 
 
ftp 
 
FTP support => enabled 
 
gd 
 
GD Support => enabled 
GD Version => bundled (2.0.11 compatible) 
GIF Read Support => enabled 
PNG Support => enabled 
WBMP Support => enabled 
XBM Support => enabled 
 
imap 
 
IMAP c-Client Version => 2001 
SSL Support => enabled 
 
mysql 
 
MySQL Support => enabled 
Active Persistent Links => 0 
Active Links => 0 
Client API version => 3.23.49 
MYSQL_MODULE_TYPE => builtin 
MYSQL_SOCKET => /tmp/mysql.sock 
MYSQL_INCLUDE => 
MYSQL_LIBS => 
 
Directive => Local Value => Master Value 
mysql.allow_persistent => On => On 
mysql.connect_timeout => -1 => -1 
mysql.default_host => no value => no value 
mysql.default_password => no value => no value 
mysql.default_port => no value => no value 
mysql.default_socket => no value => no value 
mysql.default_user => no value => no value 
mysql.max_links => Unlimited => Unlimited 
mysql.max_persistent => Unlimited => Unlimited 
mysql.trace_mode => Off => Off 
 
ncurses 
 
ncurses support => enabled 
ncurses library version => 5.3 
color support => yes 
 
overload 
 
User-Space Object Overloading Support => enabled 
 
pcre 
 
PCRE (Perl Compatible Regular Expressions) Support => 
enabled 
PCRE Library Version => 3.92 11-Sep-2002 
 
posix 
 
Revision => $Revision: 1.51.2.2 $ 
 
session 
 
Session Support => enabled 
Registered save handlers => files user 
 
Directive => Local Value => Master Value 
session.auto_start => Off => Off 
session.bug_compat_42 => On => On 
session.bug_compat_warn => On => On 
session.cache_expire => 180 => 180 
session.cache_limiter => nocache => nocache 
session.cookie_domain => no value => no value 
session.cookie_lifetime => 0 => 0 
session.cookie_path => / => / 
session.cookie_secure => Off => Off 
session.entropy_file => no value => no value 
session.entropy_length => 0 => 0 
session.gc_dividend => 100 => 100 
session.gc_maxlifetime => 1440 => 1440 
session.gc_probability => 1 => 1 
session.name => PHPSESSID => PHPSESSID 
session.referer_check => no value => no value 
session.save_handler => files => files 
session.save_path => /tmp => /tmp 
session.serialize_handler => php => php 
session.use_cookies => On => On 
session.use_only_cookies => Off => Off 
session.use_trans_sid => On => On 
 
sockets 
 
Sockets Support => enabled 
 
standard 
 
Regex Library => Bundled library enabled 
Dynamic Library Support => enabled 
Path to sendmail => /usr/sbin/sendmail -t -i 
 
Directive => Local Value => Master Value 
assert.active => 1 => 1 
assert.bail => 0 => 0 
assert.callback => no value => no value 
assert.quiet_eval => 0 => 0 
assert.warning => 1 => 1 
auto_detect_line_endings => 0 => 0 
default_socket_timeout => 60 => 60 
safe_mode_allowed_env_vars => PHP_ => PHP_ 
safe_mode_protected_env_vars => LD_LIBRARY_PATH => 
LD_LIBRARY_PATH 
url_rewriter.tags => 
a=href,area=href,frame=src,input=src,form=fakeentry => 
a=href,area=href,frame=src,input=src,form=fakeentry 
user_agent => no value => no value 
 
tokenizer 
 
Tokenizer Support => enabled 
 
xml 
 
XML Support => active 
XML Namespace Support => active 
EXPAT Version => 1.95.2 
 
zlib 
 
ZLib Support => enabled 
Compiled Version => 1.1.4 
Linked Version => 1.1.4 
 
Directive => Local Value => Master Value 
zlib.output_compression => Off => Off 
zlib.output_compression_level => -1 => -1 
zlib.output_handler => no value => no value 
 
Additional Modules 
 
Module Name 
 
Environment 
 
Variable => Value 
MANPATH => 
/usr/local/man:/usr/man:/usr/X11R6/man:/opt/gnome/man:/usr/share/texmf/man 
KDE_MULTIHEAD => false 
HZ => 100 
HOSTNAME => enzymestew.dogphilosophy.net 
SHELL => /bin/bash 
TERM => xterm 
GTK_RC_FILES => 
/etc/gtk/gtkrc:/root/.gtkrc:/root/.gtkrc-kde 
GS_LIB => /root/.kde/share/fonts 
HUSHLOGIN => FALSE 
OLDPWD => /root 
QTDIR => /usr/local/qt 
LC_ALL => POSIX 
USER => root 
LS_COLORS => 
no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.bz2=01;31:*.rpm=01;31:*.deb=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.mpg=01;37:*.avi=01;37:*.mov=01;37: 
KDEDIR => /usr/local/kde 
SESSION_MANAGER => local/enzymestew:/tmp/.ICE-unix/245 
T1LIB_CONFIG => /usr/share/t1lib/t1lib.config 
KONSOLE_DCOP => DCOPRef(konsole-258,konsole) 
MINICOM => -c on 
MAIL => /var/spool/mail/root 
PATH => 
/usr/local/sbin:/usr/sbin:/sbin:/usr/local/kde/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/games:/opt/gnome/bin:/opt/www/htdig/bin:/usr/share/texmf/bin 
KONSOLE_DCOP_SESSION => 
DCOPRef(konsole-258,session-3) 
PWD => /root/projects/biophp_code 
ignoreeof => 10 
SHLVL => 5 
HOME => /root 
LS_OPTIONS =>  --color=auto -F -b -T 0 
LESS => -M 
LOGNAME => root 
MOZILLA_HOME => /usr/lib/netscape 
LESSOPEN => |lesspipe.sh %s 
DISPLAY => :0.0 
COLORTERM => 
XAUTHORITY => /root/.Xauthority 
_ => /usr/local/bin/php 
 
PHP Variables 
 
Variable => Value 
PHP_SELF => 
_SERVER["MANPATH"] => 
/usr/local/man:/usr/man:/usr/X11R6/man:/opt/gnome/man:/usr/share/texmf/man 
_SERVER["KDE_MULTIHEAD"] => false 
_SERVER["HZ"] => 100 
_SERVER["HOSTNAME"] => enzymestew.dogphilosophy.net 
_SERVER["SHELL"] => /bin/bash 
_SERVER["TERM"] => xterm 
_SERVER["GTK_RC_FILES"] => 
/etc/gtk/gtkrc:/root/.gtkrc:/root/.gtkrc-kde 
_SERVER["GS_LIB"] => /root/.kde/share/fonts 
_SERVER["HUSHLOGIN"] => FALSE 
_SERVER["OLDPWD"] => /root 
_SERVER["QTDIR"] => /usr/local/qt 
_SERVER["LC_ALL"] => POSIX 
_SERVER["USER"] => root 
_SERVER["LS_COLORS"] => 
no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.bz2=01;31:*.rpm=01;31:*.deb=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.mpg=01;37:*.avi=01;37:*.mov=01;37: 
_SERVER["KDEDIR"] => /usr/local/kde 
_SERVER["SESSION_MANAGER"] => 
local/enzymestew:/tmp/.ICE-unix/245 
_SERVER["T1LIB_CONFIG"] => /usr/share/t1lib/t1lib.config 
_SERVER["KONSOLE_DCOP"] => 
DCOPRef(konsole-258,konsole) 
_SERVER["MINICOM"] => -c on 
_SERVER["MAIL"] => /var/spool/mail/root 
_SERVER["PATH"] => 
/usr/local/sbin:/usr/sbin:/sbin:/usr/local/kde/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/games:/opt/gnome/bin:/opt/www/htdig/bin:/usr/share/texmf/bin 
_SERVER["KONSOLE_DCOP_SESSION"] => 
DCOPRef(konsole-258,session-3) 
_SERVER["PWD"] => /root/projects/biophp_code 
_SERVER["ignoreeof"] => 10 
_SERVER["SHLVL"] => 5 
_SERVER["HOME"] => /root 
_SERVER["LS_OPTIONS"] =>  --color=auto -F -b -T 0 
_SERVER["LESS"] => -M 
_SERVER["LOGNAME"] => root 
_SERVER["MOZILLA_HOME"] => /usr/lib/netscape 
_SERVER["LESSOPEN"] => |lesspipe.sh %s 
_SERVER["DISPLAY"] => :0.0 
_SERVER["COLORTERM"] => 
_SERVER["XAUTHORITY"] => /root/.Xauthority 
_SERVER["_"] => /usr/local/bin/php 
_SERVER["PHP_SELF"] => 
_SERVER["SCRIPT_NAME"] => 
_SERVER["SCRIPT_FILENAME"] => 
_SERVER["PATH_TRANSLATED"] => 
_SERVER["DOCUMENT_ROOT"] => 
_SERVER["argv"] => Array 
( 
) 
 
_SERVER["argc"] => 0 
 
PHP License 
This program is free software; you can redistribute it and/or 
modify 
it under the terms of the PHP License as published by the 
PHP Group 
and included in the distribution in the file:  LICENSE 
 
This program is distributed in the hope that it will be useful, 
but WITHOUT ANY WARRANTY; without even the implied 
warranty of 
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 
 
If you did not receive a copy of the PHP license, or have any 
questions about PHP licensing, please contact 
license@php.net. 
 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-28 18:14 UTC] dubious at 2xtreme dot net
Quick update - don't know if it matters, but if I remove the 
"--disable-cgi" the error messages disappear...but it still 
segfaults.  (I assume this is just the CGI version suppressing 
the error message to keep from cluttering web displays?)
 [2003-03-28 18:31 UTC] dubious at 2xtreme dot net
P.S. The problem appears to be that I am an idiot :-) 
 
I mistakenly typo'd and had the method calling ITSELF rather 
than the other, similarly-named method I had intended. 
 
In other words, I caused this myself with an 
accidentally-infinitely-recursive function. 
 
Unless there is any reasonable way to expect the PHP 
interpreter to "catch" stupid things like this (or show and 
error that describes more accurately what the problem might 
be?), it's probably worth just marking this bug "bogus" and 
deleting all records of it to avoid further embarassment of 
myself...
 [2003-03-28 20:25 UTC] wez@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

as you discovered, infinite recursion causes a segfault when you run out of stack.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Mar 31 23:01:23 2020 UTC