php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22881 Input/Output filters don't seem to work anymore :-(
Submitted: 2003-03-25 13:56 UTC Modified: 2003-03-25 14:55 UTC
From: bugs at pointb dot co dot uk Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.3.2RC1 OS: RedHat 7.3
Private report: No CVE-ID:
 [2003-03-25 13:56 UTC] bugs at pointb dot co dot uk
Hi,

I have re-installed PHP as a DSO module on Apache 2.0.44 and I am unable to use the new filter options. In v4.3.1 I could use the following:

<Files *.php>
       SetOutputFilter PHP
       SetInputFilter PHP
</Files>

<Files *.phps>
       SetOutputFilter PHP
       SetInputFilter PHP
</Files>

When I use this I am prompted to download the script and I get the following in my error log:

[error] an unknown filter was not added: PHP

However if I use the older formatting with 4.3.2RC1 all works well:

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

Is this a bug, or have I missed some documentation that tells me this is no longer included?

Thanks.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-25 14:54 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Since 4.3.2RC the default Apache 2 sapi is the apache2handler and is no longer filter based. Therefor you should use
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

and not

<Files *.php>
       SetOutputFilter PHP
       SetInputFilter PHP
</Files>

If you do want to use the old filter sapi, you need to use --with-apxs2filter option.
 [2003-03-25 14:55 UTC] iliaa@php.net
read above comment.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sat May 27 11:01:38 2017 UTC