php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22873 Pb to start Apache with sybase-ct option
Submitted: 2003-03-25 08:14 UTC Modified: 2003-04-28 11:14 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: theron at cines dot fr Assigned:
Status: No Feedback Package: Sybase-ct (ctlib) related
PHP Version: 4.3.2RC1 OS: Sun solaris 8
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-03-25 08:14 UTC] theron at cines dot fr
Hello, 

I build apache 1.3.26, Sybase ASE 12.5 and php 4.2.3 (OS = Sun Solaris 8) with this
configuration:

            
./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs --enable-ftp \
 --with-gettext \
 --with-xml \
 --with-domxml \
 --with-mcrypt \
 --with-iconv \
 --enable-mbstring \
 --with-jpeg --with-jpeg-dir=/opt/jpeg-6b \
 --with-png --with-png-dir=/opt/libpng-1.2.5 \
 --with-zlib --with-zlib-dir=/opt/zlib-1.1.4 \
 --with-gd=/opt/gd-1.8.4 \
 --with-sybase-ct=/opt/sybase-12.5/OCS-12_5 \

The build of PH is ok but, when i start the apache server I have this error message:

Syntax error on line 237 of /home/admwww/cours_php/apache/conf/httpd.conf:
Cannot load /opt/php-4.2.3/.libs/libphp4.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file /opt/sybase-12.5/OCS-12_5/lib/libtcl.so: symbol comn_realloc: referenced symbol not found


The gcc compiler is gcc 3.2.2

When i build with the dblib of sybase (option --with-sybase in the config file) THERE IS NO PROBLEM TO START APACHE !

Any idea please, i'm very stoped by this problem.

Regards.
JP THERON

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-25 17:10 UTC] iliaa@php.net
What is the output of:
ldd /opt/php-4.2.3/.libs/libphp4.so
and
ldd /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
?
 [2003-03-26 02:41 UTC] theron at cines dot fr
Here are the output of the ldd cmd:

root@castor:$PWD # ldd libphp4.so
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libpam.so.1 =>   /usr/lib/libpam.so.1
        libcrypt_i.so.1 =>       /usr/lib/libcrypt_i.so.1
        libresolv.so.2 =>        /usr/lib/libresolv.so.2
        libm.so.1 =>     /usr/lib/libm.so.1
        libnsl.so.1 =>   /usr/lib/libnsl.so.1
        libsocket.so.1 =>        /usr/lib/libsocket.so.1
        libc.so.1 =>     /usr/lib/libc.so.1
        libgen.so.1 =>   /usr/lib/libgen.so.1
        libmp.so.2 =>    /usr/lib/libmp.so.2
        /usr/platform/SUNW,Ultra-Enterprise/lib/libc_psr.so.1
root@castor:$PWD # ldd /opt/sybase-12.5/OCS-12_5/lib/libtcl.so
        libsocket.so.1 =>        /usr/lib/libsocket.so.1
        libnsl.so.1 =>   /usr/lib/libnsl.so.1
        libc.so.1 =>     /usr/lib/libc.so.1
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libmp.so.2 =>    /usr/lib/libmp.so.2
        /usr/platform/SUNW,Ultra-Enterprise/lib/libc_psr.so.1

Thanks. Regards
 [2003-04-23 04:40 UTC] sniper@php.net
Is /opt/sybase-12.5/OCS-12_5/lib/ set in your LD_LIBRARY_PATH?

 [2003-04-28 11:14 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2005-10-24 12:05 UTC] sean dot healey at bayernlb dot co dot uk
This is exactly the error I am facing with PHP 5.0.5.

The problem occurs whether or not LD_LIBRARY_PATH is set, and in fact I have carefully set my LDDFLAGS -L and -R arguments to point the compiler in the right direction for the Sybase client libraries.
 [2005-10-24 12:15 UTC] sean dot healey at bayernlb dot co dot uk
(See BugID 34904)
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Jun 07 14:03:40 2023 UTC