php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22825 undefined reference to `gdFreeFontCache'
Submitted: 2003-03-22 07:06 UTC Modified: 2003-03-22 20:01 UTC
From: php-bugs at liwing dot de Assigned:
Status: Not a bug Package: GD related
PHP Version: 4.3.2RC1 OS: FreeBSD 5.0
Private report: No CVE-ID: None
 [2003-03-22 07:06 UTC] php-bugs at liwing dot de
Compiling PHP4 using port fails because of:

/bin/sh /usr/ports/www/mod_php4/work/php-4.3.2RC1/libtool --silent --preserve-dup-deps --mode=link cc -export-dynamic -O -pipe -DNO_WERROR -march=pentium2 -I/usr/local/include  -export-symbols /usr/ports/www/mod_php4/work/php-4.3.2RC1/sapi/apache/php.sym -avoid-version -module -L/usr/local/lib -L/usr/local/lib/mysql  -R /usr/local/lib -R /usr/local/lib/mysql ext/zlib/zlib.lo ext/zlib/zlib_fopen_wrapper.lo ext/bz2/bz2.lo ext/ctype/ctype.lo ext/domxml/php_domxml.lo ext/gd/gd.lo ext/gd/gdttf.lo ext/gd/gdcache.lo ext/gettext/gettext.lo ext/iconv/iconv.lo ext/ldap/ldap.lo ext/mcrypt/mcrypt.lo ext/mhash/mhash.lo ext/mysql/php_mysql.lo ext/openssl/openssl.lo ext/overload/overload.lo ext/pcre/pcrelib/maketables.lo ext/pcre/pcrelib/get.lo ext/pcre/pcrelib/study.lo ext/pcre/pcrelib/pcre.lo ext/pcre/php_pcre.lo ext/pdf/pdf.lo ext/posix/posix.lo ext/session/session.lo ext/session/mod_files.lo ext/session/mod_mm.lo ext/session/mod_user.lo ext/sockets/sockets.lo ext/standard/array.lo ext/standard/base64.lo ext/standard/basic_functions.lo ext/standard/browscap.lo ext/standard/crc32.lo ext/standard/crypt.lo ext/standard/cyr_convert.lo ext/standard/datetime.lo ext/standard/dir.lo ext/standard/dl.lo ext/standard/dns.lo ext/standard/exec.lo ext/standard/file.lo ext/standard/filestat.lo ext/standard/flock_compat.lo ext/standard/formatted_print.lo ext/standard/fsock.lo ext/standard/head.lo ext/standard/html.lo ext/standard/image.lo ext/standard/info.lo ext/standard/iptc.lo ext/standard/lcg.lo ext/standard/link.lo ext/standard/mail.lo ext/standard/math.lo ext/standard/md5.lo ext/standard/metaphone.lo ext/standard/microtime.lo ext/standard/pack.lo ext/standard/pageinfo.lo ext/standard/parsedate.lo ext/standard/quot_print.lo ext/standard/rand.lo ext/standard/reg.lo ext/standard/soundex.lo ext/standard/string.lo ext/standard/scanf.lo ext/standard/syslog.lo ext/standard/type.lo ext/standard/uniqid.lo ext/standard/url.lo ext/standard/url_scanner.lo ext/standard/var.lo ext/standard/versioning.lo ext/standard/assert.lo ext/standard/strnatcmp.lo ext/standard/levenshtein.lo ext/standard/incomplete_class.lo ext/standard/url_scanner_ex.lo ext/standard/ftp_fopen_wrapper.lo ext/standard/http_fopen_wrapper.lo ext/standard/php_fopen_wrapper.lo ext/standard/credits.lo ext/standard/css.lo ext/standard/var_unserializer.lo ext/standard/ftok.lo ext/standard/aggregation.lo ext/standard/sha1.lo ext/sysvsem/sysvsem.lo ext/sysvshm/sysvshm.lo ext/tokenizer/tokenizer.lo ext/xml/xml.lo ext/xmlrpc/xmlrpc-epi-php.lo ext/xmlrpc/libxmlrpc/base64.lo ext/xmlrpc/libxmlrpc/simplestring.lo ext/xmlrpc/libxmlrpc/xml_to_dandarpc.lo ext/xmlrpc/libxmlrpc/xmlrpc_introspection.lo ext/xmlrpc/libxmlrpc/encodings.lo ext/xmlrpc/libxmlrpc/system_methods.lo ext/xmlrpc/libxmlrpc/xml_to_xmlrpc.lo ext/xmlrpc/libxmlrpc/queue.lo ext/xmlrpc/libxmlrpc/xml_element.lo ext/xmlrpc/libxmlrpc/xmlrpc.lo ext/xmlrpc/libxmlrpc/xml_to_soap.lo ext/xslt/xslt.lo ext/xslt/sablot.lo regex/regcomp.lo regex/regexec.lo regex/regerror.lo regex/regfree.lo TSRM/TSRM.lo TSRM/tsrm_strtok_r.lo TSRM/tsrm_virtual_cwd.lo main/main.lo main/snprintf.lo main/spprintf.lo main/php_sprintf.lo main/safe_mode.lo main/fopen_wrappers.lo main/alloca.lo main/php_scandir.lo main/php_ini.lo main/SAPI.lo main/rfc1867.lo main/php_content_types.lo main/strlcpy.lo main/strlcat.lo main/mergesort.lo main/reentrancy.lo main/php_variables.lo main/php_ticks.lo main/streams.lo main/network.lo main/php_open_temporary_file.lo main/php_logos.lo main/output.lo main/memory_streams.lo main/user_streams.lo Zend/zend_language_parser.lo Zend/zend_language_scanner.lo Zend/zend_ini_parser.lo Zend/zend_ini_scanner.lo Zend/zend_alloc.lo Zend/zend_compile.lo Zend/zend_constants.lo Zend/zend_dynamic_array.lo Zend/zend_execute_API.lo Zend/zend_highlight.lo Zend/zend_llist.lo Zend/zend_opcode.lo Zend/zend_operators.lo Zend/zend_ptr_stack.lo Zend/zend_stack.lo Zend/zend_variables.lo Zend/zend.lo Zend/zend_API.lo Zend/zend_extensions.lo Zend/zend_hash.lo Zend/zend_list.lo Zend/zend_indent.lo Zend/zend_builtin_functions.lo Zend/zend_sprintf.lo Zend/zend_ini.lo Zend/zend_qsort.lo Zend/zend_multibyte.lo Zend/zend_execute.lo sapi/cli/php_cli.lo sapi/cli/getopt.lo main/internal_functions_cli.lo -lcrypt -lsablot -lexpat -lexpat -lexpat -lexpat -lcrypt -lpdf -lz -ltiff -lpng -ljpeg -lmysqlclient -lmhash -lmcrypt -lltdl -lldap -llber -liconv -lintl -lgd -lfreetype -lpng -lz -ljpeg -lexslt -lxsltbreakpoint -lxml2 -lxslt -lz -lbz2 -lz -lssl -lcrypto -lm -lxml2 -lz -liconv -lm -lcrypt -lcrypt  -o sapi/cli/php
ext/gd/gd.lo: In function `zm_deactivate_gd':
ext/gd/gd.lo(.text+0x875): undefined reference to `gdFreeFontCache'
*** Error code 1

Stop in /usr/ports/www/mod_php4/work/php-4.3.2RC1.
*** Error code 1

Stop in /usr/ports/www/mod_php4.
*** Error code 1

Stop in /usr/ports/www/mod_php4.

Using the bundled gd may work, but breaks the FreeBSD-Port and keeps harder to maintain because of 2 installed versions of gd.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-22 08:21 UTC] magnus@php.net
How can you get two installed version of GD by using the bundled one ?
You don't need gd installed to use the bundled gd, that is the point of bundling libs.

 [2003-03-22 09:04 UTC] php-bugs at liwing dot de
It's quite easy - having a common gd-library installed (using port) which is used by all dependend applications and having a second one which comes with php. Counting 1 + 1 becomes 2 (decimal system).

Clear so long?

Jens
 [2003-03-22 14:07 UTC] magnus@php.net
From Boutell's homepage (GD page):
"If you wish to use gd with PHP, it is probably best to get php 4.3.0 and use the included gd library."
 [2003-03-22 18:32 UTC] sniper@php.net
The common user error of mixing different GD headers with different libs. Not PHP bug.

 [2003-03-22 20:01 UTC] php-bugs at liwing dot de
The error came up when php is build from ports. By the way, php-4.3.1 didn't fail, so there must be changed sth.. Is it real difficult for developers to check what's wrang and correct it?

Maybe there is a small error in autoconf which make php to use it's own headers but link against libgd2.so in /usr/local/lib/? I think it's worth to prove to make a fine release :-)

I can easily live without gd-support, I just tested it...
 [2003-06-09 16:36 UTC] alasdair at alivewww dot com
I'm having exactly the same problem.

PHP 4.3.2 (the final version not the RC) fails to compile when you ask it to use the installed system version of GDLib.

This is not a bogus or closed bug - a perfectly valid installation of GDLib 2.0.1 is present, and PHP 4.3.1 compiles without problem.

The system I'm using is FreeBSD 4.7-RELEASE, with Apache 1.3.27.

If there is any other information that may help find the cause of this bug, please let me know so I can post it.
 [2004-03-23 22:30 UTC] swingcoder at msn dot com
yes,i meet this problem with php-4.3.4 with apache 2.0
and fix it use php4-STABLE-latest.tar.tar(http://snaps.php.net/php4-STABLE-latest.tar.gz) the latest replease!!!
anybody can try this!!
 [2004-04-14 03:33 UTC] bgs at bgs dot hu
I'm also having this problem with apache2 and both php 4.3.4 and latest.

When build with the bundled gd, it compiles well. When compiled against the latest gd library it fails.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 00:01:23 2020 UTC