php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22811 Apache2 start failure
Submitted: 2003-03-21 03:32 UTC Modified: 2003-04-01 03:47 UTC
From: sstar at cien dot ru Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.3.1 OS: Win2K SP2
Private report: No CVE-ID: None
 [2003-03-21 03:32 UTC] sstar at cien dot ru
Apache2 don't start with php 4.3.1 module (not CGI) added (php4apache2.dll). The following text appears in system event log:
Event Type:	Error
Event Source:	Apache Service
Event Category:	None
Event ID:	3299
Date:		20.03.2003
Time:		22:27:18
User:		N/A
Computer:	STARPRO
Description:
The Apache service named  reported the following error:
>>> Apache.exe: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" is not compatible with this version of Apache.

Apache 1.3.26 with PHP4.3.1 is working properly. 
Apache2 with PHP4.2.3 is working properly. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-21 10:03 UTC] magnus@php.net
What version of Apache2 ?
 [2003-03-21 10:06 UTC] sstar at cien dot ru
Apache 2.0.40
 [2003-03-21 16:02 UTC] moriyoshi@php.net
Please try the latest Apache2 release(2.0.44).

 [2003-03-28 06:15 UTC] sstar at cien dot ru
Release 2.0.44 works correctly
 [2003-03-28 06:19 UTC] sstar at cien dot ru
thanx
 [2003-04-01 03:47 UTC] moriyoshi@php.net
Let me mark this PR as bogus because this turned out to not be a bug in php after all.

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 08:01:27 2024 UTC