php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22780 DSO load warnings + crash behaviour
Submitted: 2003-03-18 22:06 UTC Modified: 2003-07-14 18:01 UTC
From: chriskl at familyhealth dot com dot au Assigned: edink (profile)
Status: Wont fix Package: Apache related
PHP Version: 4.3.2RC1 OS: Win2K
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chriskl at familyhealth dot com dot au
New email:
PHP Version: OS:

 

 [2003-03-18 22:06 UTC] chriskl at familyhealth dot com dot au
This is a duplicate of bug #5205, but that bug was closed and the official PHP disto has not been fixed.

I get this starting latest PHP with Apache:

[Wed Mar 19 12:03:44 2003] [warn] Loaded DSO c:/php/php4apache.dll uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEPI)

I have gotten this error with 4.3.0 as well.  This is using official PHP project everything.

It DOES cause crashes.  I'm just browsing my local site and every once in a while it just stops and gives a blank page on a PHP page.  I hit refresh about 20 times and it fixes itself.  This is truly annoying behaviour.

Chris

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-19 02:29 UTC] sniper@php.net
Edin: Would it be possible to provide the EAPI enabled apache module??

 [2003-07-14 18:01 UTC] edink@php.net
Our build envirnment is not capable of having two different sets Apache libraries and header files.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri May 24 07:01:26 2019 UTC