php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22776 error parsing php.ini - MS-DOS short filename
Submitted: 2003-03-18 21:06 UTC Modified: 2003-03-19 15:44 UTC
Votes:4
Avg. Score:4.2 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:1 (33.3%)
From: vbhackattack at hotmail dot com Assigned:
Status: Wont fix Package: PHP options/info functions
PHP Version: 4.3.2RC1 OS: Windows 2000
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-03-18 21:06 UTC] vbhackattack at hotmail dot com
When loading php.exe reports a non-fatal error when parsing php.ini:
PHP:  Error parsing F:\WINNT\php.ini on line 424

where php.ini line 424 is:
extension_dir = F:/PROGRA~1/phpdev/php/extensions

Changing to a long filename is a work around. It doesn't seem to matter if a long filename containing spaces is quoted. The following seems to work, although I have no idea how to throughly test this.
extension_dir = F:/Program Files/phpdev/php/extensions

I tried to explore this but it involves Bison parsing of the ini file and I got lost in the muddle of identifiers all starting with "yy".

Tested with v4.3.1, v4.3.2RC1, v4.5.x and v5.0.x.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-19 02:01 UTC] sniper@php.net
This is just how it works on windows..

 [2003-03-19 07:01 UTC] vbhackattack at hotmail dot com
Before changing the status to "Bogus", could you elaborate on why this bug can't be fixed? This is bound to cause confusion for PHP newbies (as I was a month ago).
 [2003-03-19 10:47 UTC] sniper@php.net
Always use "'s around the paths.This won't give any errors:

extension_dir = "F:/PROGRA~1/phpdev/php/extensions"


 [2003-03-19 15:18 UTC] vbhackattack at hotmail dot com
Being a relative newbie to www.php.net and not knowing who the players are it is hard to know how to read spider's two comments. As far as I can tell, this is a legitimate bug with a workaround, not a bogus issue. I'd welcome any evidence to the contrary.

Maybe Status = "Bogus" is shorthand for a variety of states including: workaround, on-hold, rejected and open-low-priority, etc. In which case it is a poor choice of nomenclature. After losing some time and mental effort on this bug, and being conscientious to take the time to report it, I'd appreciate not being told my report is bogus, at least without some evidence.

If we want to encourage development of a top quality product in PHP, shouldn't we strive to eliminate bugs rather than hiding them behind workarounds and bogus status such as "Bogus"?

Since my comment is straying away from the bug report and into philosophy, I invite follow up comments to the mailing lists php-dev, php-qa or wherever discussion and advocacy take place :)

P.S. How about a directory of cvs contributors with a brief bio so we can learn more about who we all are.

P.P.S. According to my tests, quotes around a path in php.ini are not needed when there are spaces in the path, at least for initial parsing of the ini file. Funny that spaces are OK but ~'s are not.
 [2003-03-19 15:44 UTC] sniper@php.net
If you prefer 'wont fix', fine.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jul 15 22:01:26 2019 UTC