php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22745 configure fail on sybase-ct check if defined enable-sybase
Submitted: 2003-03-17 09:41 UTC Modified: 2003-03-17 09:57 UTC
From: php-bugs at i dot org dot ua Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.3.2RC OS:
Private report: No CVE-ID: None
 [2003-03-17 09:41 UTC] php-bugs at i dot org dot ua
Hi

Branch: PHP_4_3, updated at 03/17/2003.

configure script failed if defined --enable-sybase directive with error 'You can not use both --with-sybase and --with-sybase-ct in same build'.

this patch fix the problem... maybe.

--- ext/sybase_ct/config.m4.old 2003-03-17 17:20:59.479999000 +0200
+++ ext/sybase_ct/config.m4     2003-03-17 17:21:56.159999000 +0200
@@ -6,11 +6,11 @@
 [  --with-sybase-ct[=DIR]  Include Sybase-CT support.  DIR is the Sybase home
                           directory. Defaults to /home/sybase.])

-if test "$PHP_SYBASE" != "no"; then
-  AC_MSG_ERROR([You can not use both --with-sybase and --with-sybase-ct in same build!])
-fi
-
 if test "$PHP_SYBASE_CT" != "no"; then
+       if test "$PHP_SYBASE" != "no"; then
+        AC_MSG_ERROR([You can not use both --with-sybase and --with-sybase-ct in same build!])
+       fi

PS: don't forget run ./buildconf

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-17 09:57 UTC] sniper@php.net
Oops. That was my mistake, thanks for catching this.
(fixed in CVS now)

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Apr 23 03:01:26 2021 UTC