php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2263 Crash when reloading include file with arrays
Submitted: 1999-09-08 10:21 UTC Modified: 1999-09-08 11:58 UTC
From: wico at cnh dot nl Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0 Latest CVS (08/09/1999) OS: linux redhat 6
Private report: No CVE-ID: None
 [1999-09-08 10:21 UTC] wico at cnh dot nl
i f have a global.inc that every page uses...

in the glolbal.inc i have these arrays:

		$enq_cijfer_totaal[] = "Welk cijfer geeft u aan de vormgeving van de total CNH website?";
		$enq_cijfer_totaal[] = "Zeer goed (9-10)";
		$enq_cijfer_totaal[] = "Goed (7-8)";
		$enq_cijfer_totaal[] = "Gemiddeld (6)";
		$enq_cijfer_totaal[] = "Matig (5)";
		$enq_cijfer_totaal[] = "Zeer matig (0 - 4)";
		
		$enq_cijfer_inhoud[] = "Welk cijfer geeft u aan de inhoud van de totale CNH website?";
		$enq_cijfer_inhoud[] = "Zeer goed (9-10)";
		$enq_cijfer_inhoud[] = "Goed (7-8)";
		$enq_cijfer_inhoud[] = "Gemiddeld (6)";
		$enq_cijfer_inhoud[] = "Matig (5)";
		$enq_cijfer_inhoud[] = "Zeer matig (0 - 4)"; 
		
		$enq_cijfer_vriendelijk[] = "Welk cijfer geeft u aan de gebruikersvriendelijkheid van de totale CNH website?";
		$enq_cijfer_vriendelijk[] = "Zeer goed (9-10)";
		$enq_cijfer_vriendelijk[] = "Goed (7-8)";
		$enq_cijfer_vriendelijk[] = "Gemiddeld (6)";
		$enq_cijfer_vriendelijk[] = "Matig (5)";
		$enq_cijfer_vriendelijk[] = "Zeer matig (0 - 4)"; */

and lot's more but these makes it crash...

the first time the page is loaded everything goes well,,
but when i do a submit to the same page it crashes with:
[Wed Sep  8 15:16:30 1999] [notice] child pid 3938 exit signal Segmentation fault (11)

when i comment out these arrays everything goes wel...
does it have to do with the dashes?

P.S the values of the arrays are a rating in Dutch if you where wondering :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-09-08 11:58 UTC] wico at cnh dot nl
Bug is somewhere else... will let know when i find it...

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Oct 26 10:01:22 2020 UTC