php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22617 www.php.net language
Submitted: 2003-03-09 23:02 UTC Modified: 2003-03-21 09:59 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: jtjohnston at courrier dot usherb dot ca Assigned:
Status: Closed Package: Website problem
PHP Version: 4.3.1 OS:
Private report: No CVE-ID: None
 [2003-03-09 23:02 UTC] jtjohnston at courrier dot usherb dot ca
Website or cookie problem??
When I search for something in the manual at www.php.net, my searches now respond in French. I use an English browser (although my OS (Win98) is French).
I get this
http://www.php.net/manual/fr/function.mysql-fetch-array.php
instead of
http://www.php.net/manual/en/function.mysql-fetch-array.php
for example.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-09 23:16 UTC] rioter@php.net
check your browers accepted languages im assuming because your OS is in french PHP.net is pulling french you can change your language in Tools/Internet Options/Languages

 [2003-03-10 00:17 UTC] jtjohnston at courrier dot usherb dot ca
I admit, [Fr] is the second accepted language. But English [En] is the first!?
 [2003-03-10 00:18 UTC] jtjohnston at courrier dot usherb dot ca
It worked until this past week some time
 [2003-03-10 06:21 UTC] andrew@php.net
This is a new feature of php.net, auto-accepting languages, as noticed on the http://www.php.net homepage.

Marking as bogus.

~ Andrew Heebner
 [2003-03-10 15:29 UTC] jtjohnston at courrier dot usherb dot ca
Works badly!
 [2003-03-10 15:37 UTC] jtjohnston at courrier dot usherb dot ca
Works badly!
> "Accept Language" setting is also honored on 
> language sensitive pages ... You can set your
> preferences under Edit/Preferences/Navigator/Languages
> in Mozilla

English is my first set langauge, [fr] is the second. It should not pick up on Fr? At least when I switch languages on a manual reference page to go from Fr to En, my cookie should at least recognise that I switched to En? Set up a page for users to change their preferences so their cookie is configured to their liking?
:) J
 [2003-03-10 17:14 UTC] sniper@php.net
Please keep these in the correct category.

 [2003-03-10 22:12 UTC] jtjohnston at courrier dot usherb dot ca
It is in the correct category.
 [2003-03-11 08:24 UTC] goba@php.net
1. It is in the right category, but it was not. Sniper changed the category...

2. I have sent a patch yesterday to the guys to fix your "at least" problem, so if you start from an english page, and search for anything, it stays is English mode, regardless of what is your preferred language.

3. Can you please send in your exact accept-language header contents? Many browsers allow you to get the header information.

4. We have talked about a cookie to add, so if your normal accept-language setting is not right for php.net you will be able to set it otherwise. Please be a bit patient with this.
 [2003-03-19 16:48 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-03-21 02:14 UTC] jtjohnston at courrier dot usherb dot ca
>we assume that you are no longer experiencing the problem

Sorry for the delay in answering.

>sent a patch yesterday

Everything appears to work. Indeed I received this message, without ever asking for it :) :

"Welcome back! Since you opted to store your bug's password in a cookie, you can just go ahead and add more information to this bug or edit the other fields. "

>Can you please send in your exact accept-language header content

Not sure how to get that other than in preferences. I use English "En" first and French "Fr" second.

Can you post code someplace that will allow me too to check for language and make decisions based thereon. Yours works now. Great!

> you will be able to set it otherwise

I don't see that anywhere just yet, but look forward to it.
 [2003-03-21 09:59 UTC] goba@php.net
Well, we are beta testing a new page, http://php.net/my which displays all languages affecting the automatic language selection. You can also get a list of your parsed accept-language header, etc. Now we remember the last seen language, and you can have a setting, which overrides everything when using a shortcut...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Apr 13 21:01:23 2021 UTC