php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22573 Crash when Zlib enabled
Submitted: 2003-03-06 14:00 UTC Modified: 2003-03-06 15:30 UTC
From: agustinchernitsky at hotmail dot com Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 4.3.1 OS: Win2k SP3 Server
Private report: No CVE-ID: None
 [2003-03-06 14:00 UTC] agustinchernitsky at hotmail dot com
I upgraded from 4.2.3 to 4.3.1.

When I opened a php page, I got a CGI timeout error message. Since I didn?t change my php.ini, I rechecked everything.

Still, nothing wrong.... So I noticed that php_zlib.dll extension was enabled. I commented out that extensions and there... everything worked!

It seems that something is not working well. The rest of the extensions are OK.

In ISAPI mode, the IIS service doesn?t even  start.

Hope it helps.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-06 15:30 UTC] moriyoshi@php.net
zlib extension is now built-in and enabled by default, so you don't need to explicitly enable it in your php.ini.

See news.txt for detail.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 09:01:25 2020 UTC