php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22569 accentuated characters OpenLDAP Apache2 PHP
Submitted: 2003-03-06 09:50 UTC Modified: 2003-03-11 20:17 UTC
From: jmorvan at sdd dot fr Assigned:
Status: No Feedback Package: LDAP related
PHP Version: 4.2.3 OS: RedHat 7.3
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-03-06 09:50 UTC] jmorvan at sdd dot fr
Accentuated characters

accentuated characters not managed by request PHP towards a OpenLDAP waiter via apache2.

defaultCharset is iso-8859-1 in php.ini
all Characters "?;?;?;?;...." are replaced by generic characters.

OpenLdap functions work correctly with other customer applications of LDAP requests.

ex: in openLdap "syt?mes" = "systèmes" with php + Apache2 

short script function:
###############search#######################
if ($ds) {
            $r=ldap_bind($ds); // Ceci est un lien "anonymous", typiquement
            // Recherche dans les noms
            $sr=ldap_search($ds, $LDAP_BASE_DN, "l=$_POST[site]");
            $infoLdap = ldap_get_entries($ds, $sr);
            ldap_close($ds);
         }

###############Result Printing###############     
$infoLdapTri = array("vide" => array("vide" => "vide"));
        for ($i=0; $i<$infoLdap["count"]; $i++) {
                $infoLdapTri["sn"][$i] = $infoLdap[$i]["sn"][0];
                $infoLdapTri["givenname"][$i] = $infoLdap[$i]["givenname"][0];
                $infoLdapTri["mail"][$i] = $infoLdap[$i]["mail"][0];
                $infoLdapTri["homephone"][$i] = $infoLdap[$i]["homephone"][0];
                $infoLdapTri["site"][$i] = $infoLdap[$i]["l"][0];
                $infoLdapTri["uid"][$i] = $infoLdap[$i]["uid"][0]; 
        }
        array_multisort($infoLdapTri["sn"], SORT_STRING, SORT_ASC, $infoLdapTri[
"givenname"], $infoLdapTri["mail"], $infoLdapTri["homephone"], $infoLdapTri["sit
e"], $infoLdapTri["uid"]);

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-06 13:03 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

And if this happens with it too, try with the CLI binary.
If it happens with the CLI binary too:

1. What openldap version?
2. Are you sure it isn't that array_multisort() that causes this? replace that result printing with var_dump() call.
 [2003-03-11 20:17 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-05-04 05:24 UTC] gsivathanu at msn dot com
Will this by any chance affect LDAP authentication in OpenLDAP using ldap_bind () ??

Gopalan Sivathanu
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 13:01:47 2020 UTC