php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22564 header Location problem
Submitted: 2003-03-05 23:31 UTC Modified: 2003-04-09 11:23 UTC
From: msanders at primary dot net Assigned:
Status: Not a bug Package: CGI/CLI related
PHP Version: 4.2.3 OS: Windows NT 5.0 build 2195
Private report: No CVE-ID: None
 [2003-03-05 23:31 UTC] msanders at primary dot net
This is a very unusual problem we are having with the header(Location: urlinfo) function. On one system we are getting this error "CGI Error The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are". If we refresh the page a couple of times the desired redirected page is displayed. On another system we are not having any problems. The page gets redirected immediately. The other system is also Windows NT 5.0 build 2195. It is also PHP version 4.2.3. The only difference on the PHP configurations between the two boxes is php is installed on the d drive while the other is installed on the c drive. On both machines the websites lives on the d drive. I cannot find any IIS configuration differences between the two machines. I have rebooted the machine that is having the problems to see if I am getting cached pages. However this did not help. Also both machines are using only php_curl and php_mssql extensions. I am pretty sure that this is a configuration problem, however I cannot see any differences in either IIS or PHP configuration between these two machines other than where php is installed.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-06 11:12 UTC] pollita@php.net
1) What is the exact text of your script? (Copy and Paste or provide URL to .phps, do *NOT* summarize or othewise reduce the content)

2) Are you running PHP as a CGI or as an ISAPI dll?

3) Is there anyway you can try using 4.3.1 or (better yet) a snapshot?  If you can't permanently put 4.3.1 on the server in question for some reason, could you at least try running it there temporarily to see if it makes a difference?
 [2003-03-06 12:42 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

..and DO NOT add such long scripts here, post an URL to a .txt file instead.

 [2003-03-11 20:17 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-04-09 11:23 UTC] jmoore@php.net
This looks like an instance of the permissions problem mentioned in many other bug reports on this subject, Bug 9852 seems to be where most comments are being made...

Please check permissions on ALL of your dll's related to MSSQL, PHP and the PHP files themselves and make sure IUSER_.... or whatever your IIS server runs as has access to them (A quick way to test is to set the IIS Server to run an yourself and see if it fails then, you should not however run your server in this state for long due to security implications.)

- James
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC