php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22563 The specified CGI application misbehaved by not returning a complete set of HTT
Submitted: 2003-03-05 21:50 UTC Modified: 2006-03-14 18:29 UTC
Votes:8
Avg. Score:4.4 ± 0.9
Reproduced:7 of 7 (100.0%)
Same Version:2 (28.6%)
Same OS:2 (28.6%)
From: frankielam at ucr dot com dot hk Assigned:
Status: Not a bug Package: CGI/CLI related
PHP Version: 4.3.1 OS: Windows 2000
Private report: No CVE-ID: None
 [2003-03-05 21:50 UTC] frankielam at ucr dot com dot hk
I find the CGI error occurs intermittently with the php script below(a simple script that
do nothing but keeps refreshing itself with a different value of parameter passed into it as GET, REMEMBER to open serveral instances to
run it.)

Teh message it returns is:
"CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:"

doit.php
8<-----------------------------------------------
<?
echo "<html><head><title>testing</title>";
if (isset($_GET["times"]))
	$times = ($_GET["times"]) + 1;
else
	$times = 0;

//SEE??? even i comment the statement out, infamous cgi error occurs,
STILL!
//$conn = mssql_connect('127.0.0.1', 'sa', '') or die("couldn't
connect");
echo "<meta http-equiv=\"Refresh\" content=\"0; URL=doit.php?times=" .
$times . "\"></head></html>";
echo "Trying CGI";
echo "<BR>$times";
//header("doit.php");
?>
8<-----------------------------------------------

My config.:
Windows 2000 Advanced Server with SP3
PHP 4.3.1 / 4.2.3 (both tested to have CGI problem)
P3-1G with 128MB RAM

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-10 20:39 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-07-05 04:58 UTC] johan at onsvala_dot_mine dot nu
I get
"CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers."

I run PHP as CGI on Windows 2003 Server Web Edition. Same error occurs on W2K, but not as often. I have a frameset consisting of about 10 different frames, of which about 6-7 loads PHP-pages. When refreshing the page I get the above mentioned error in one (any) of the PHP-containing frames at least 1 time out of 50, sometimes more. MS says this error occurs when the PHP-process ends prematurely, so the question is - why?

johan@onsvala_dot_mine.nu
 [2006-03-14 18:20 UTC] gorkaludlow at hotmail dot com
This is not a bug, what happens is that if you include a file into itself php starts a never ending loop that crashes CGI.

IAM

Gorka
 [2006-03-14 18:29 UTC] tony2001@php.net
.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 12:01:24 2020 UTC