php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22541 php_xslt.dll will not load with sablot.dll compiled with iconv support
Submitted: 2003-03-04 15:55 UTC Modified: 2003-03-04 19:30 UTC
From: brandon dot whitehead at orst dot edu Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.3.0 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: brandon dot whitehead at orst dot edu
New email:
PHP Version: OS:

 

 [2003-03-04 15:55 UTC] brandon dot whitehead at orst dot edu
Me <- one of those frustrated Win32 binary users.  Using Apache 2.x.  Related to Bug # 19092

I am trying to run Sablotron through PHP with iconv support.  When originally trying to get php_xslt.dll to load, I ran into a situation like in bug 19092.  I eventually got it all working per the last entry in that report.  I am fairly certain it was a matter of getting all the right versions.

However, the version of sablot.dll was not compiled with support for iconv.dll, even though iconv 1.7 is installed (and running per phpinfo).  You have to use the version of sablot.dll that is designed to work with iconv.dll.

However, when I tried to replace my working sablot.dll with the version that is compiled to work with iconv, I once again run into the same problem mentioned in 19092.

Not wanting to break a system that currently works, I am asking here if there is a bundle of Sablotron, Expat, PHP and Iconv that actually work together?

If not, could this be included in the next Win32 binary release?

Brandon Whitehead

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-04 19:30 UTC] sniper@php.net
Yes, they will be in next release, and there have been such in last releases too. Not a bug in PHP. 

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Nov 23 01:01:24 2019 UTC