php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19092 Cannot load php_xslt.dll
Submitted: 2002-08-25 14:25 UTC Modified: 2002-08-30 18:08 UTC
From: tony at marston-home dot demon dot co dot uk Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.2.2 OS: Windows ME
Private report: No CVE-ID: None
 [2002-08-25 14:25 UTC] tony at marston-home dot demon dot co dot uk
When I try to enable 'extension=php_xslt.dll' in my php.ini file I get the following error when I start to start up Apache:

"Unable to load dynamic library F:/php/extensions/php_xslt.dll - one of the library files needed to run this application cannot be found"

When I look at php_xslt.dll with Dependency Walker it tells me that file APPHELP.DLL and USERENV.DLL are referenced but could not be found on my system. It also tells me that these files are being referenced from within SHLWAPI.DLL.

What can I do to get this extension to work?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-25 18:30 UTC] edink@php.net
php_xslt.dll depends on sablot.dll which is in the dlls subdir of the php distribution. You have most likely forgotten to copy dlls to you system directory.
 [2002-08-30 17:33 UTC] tony at marston-home dot demon dot co dot uk
SOLVED!! I originally had all the PHP .dll files in the /php/extensions folder, and everything ran from there without a problem. It was when I tried to enable the php_xslt.dll that I started getting error messages about "unable to load dynamic library...". I checked it with Dependency Walker and this showed that two dll files were missing.

It was suggested that I move all the dlls into the c:\windows\system folder, which I did, but when I checked with Dependency Walker the errors were still there. Because of the errors I did not try to run PHP with the xslt module enabled. But just today I enabled it so that I could check the error message again, but it did not appear!

This seems strange because Dependency Walker will show the same errors whether the file is in the /php/extensions folder or the windows/system folder, but putting everything in the windows/system folder will NOT produce a runtime error.

I can now access the xslt module, so this problem is now closed. Thanks for your efforts.
 [2002-08-30 17:37 UTC] edink@php.net
Exactly as documented.
User error => Bogus
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 17:01:35 2019 UTC