php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22457 gmmktime, gmdate bug
Submitted: 2003-02-27 08:08 UTC Modified: 2003-02-27 08:44 UTC
Votes:19
Avg. Score:3.8 ± 1.0
Reproduced:10 of 11 (90.9%)
Same Version:2 (20.0%)
Same OS:7 (70.0%)
From: nospam at null dot dev Assigned:
Status: Wont fix Package: Date/time related
PHP Version: 4.3.1 OS: Windows 2000
Private report: No CVE-ID:
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-02-27 08:08 UTC] nospam at null dot dev
Please someone reopen bug ID 14391, which is currently on 'no feedback'.

The gmmktime() & windows problem still persists on 4.3.0. 

We now go into the third year of this bug being around. Could this become a record???
Testcase: 
   gmmktime(0,0,0,1,1,1970);
MUST return 0, also on a win box that is not in GMT-Zone.

Or then, PLEASE introduce URGENTLY a new function that allows the manual correction of the TZ:


int gmmktime ( int hour, int minute, int second, int month, int day, int year [, int is_dst] [, int tz_offset])

because it boils down to the fact that the TZ-offset is the thing that is not detected correctly.

---------
this note will also be posted to bug 14391, so you can remove this bug after reopening 14391!!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-27 08:44 UTC] iliaa@php.net
In *nix systems you can modify the offset by specifying the TZ system variable. That said, gm* time/date functions will always return GMT time/date that is un affected by timezone settings.
 
PHP Copyright © 2001-2016 The PHP Group
All rights reserved.
Last updated: Tue Aug 30 15:01:35 2016 UTC