|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22425 session_start() causes apache segfault/crash
Submitted: 2003-02-26 00:11 UTC Modified: 2003-03-25 22:24 UTC
Avg. Score:5.0 ± 0.0
Reproduced:6 of 6 (100.0%)
Same Version:3 (50.0%)
Same OS:0 (0.0%)
From: addinitz at hotmail dot com Assigned:
Status: No Feedback Package: Session related
PHP Version: 4.3.1 OS: Gentoo Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-02-26 00:11 UTC] addinitz at hotmail dot com
version 4.2.3 works fine when I call the session_start 
function, but in both 4.3.0 and 4.3.1, session_start() causes 
an immediate crash. 
The OS is Gentoo Linux 1.4_rc2.  Apache 2.0.44. 


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-26 00:58 UTC]
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

 [2003-03-09 19:14 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

 [2003-03-25 20:42 UTC] juvenal dot jr at uol dot com dot br
I'm having the same problem here (PHP 4.3.1) but with RH 7.3 with the latest packages from RHN (apache-1.3.27-2, glibc-2.2.5-43), and a kernel with SGI XFS patches applied (kernel-2.4.18-4SGI_XFS_1.1). When compiled with --disable-debug, I got the Segmentation fault problem with session_start(), but when I use --enable-debug on compile, the SEGV vanishes. I'd like to ask if there is another way to get important info to fix it (I cannot use the --enable-debug version because I need Zend Optimizer and Zend Debugger, and they only work with the --disable-debug version of PHP).
I'm waiting your answer.


Juvenal A. Silva Jr.
 [2003-03-25 22:24 UTC]
sounds like some optimization problem in the compiler.
 [2005-06-05 19:29 UTC] till at klimpong dot com
I have the same problem in PHP 4.3.11 and FreeBSD 4.10.
 [2005-06-06 10:35 UTC] till at klimpong dot com
Ok, here is my fix.

*Although* I had installed everything from scratch, I just went into the /usr/ports/www/php4-session directory, and issued "make deinstall".

Then restarted Apache to reflect changes - worked.

Then I did, "make clean && make install", and reinstalled the session extension again. Restarted Apache, and the segfaults are gone.

Hope this helps!
 [2005-07-08 14:29 UTC] mszumocki at contman dot pl
Observed same issue on FreeBSD 5.2 with PHP 4.3.11 and Apache 2.0.54. Klimpong's 'fix' worked - i suspect it might have something to do with order of loading extension .so files in .ini file.
 [2005-08-23 16:51 UTC] ben_as_usual at yahoo dot com
I just experienced the exact same problem on PHP 4.3.8 and Apache 2.0.50/Suse 9.3.

After reading mszumocki's comment above, I just changed the order of the extensions in my php.ini, so that will be loaded last and now it works like a charm!

My php.ini like it was before ("" inserted as first extension by SuseConfig I assume):

[extension section]
; end of extension section

And my changed extensions, now will be loaded last:

[extension section]
; end of extension section

Hope it helps someone!
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Jun 07 15:03:42 2023 UTC