php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22376 wrong httpd.conf modified when using INSTALL_ROOT
Submitted: 2003-02-22 11:12 UTC Modified: 2003-02-23 01:36 UTC
From: Joerg dot Dieter dot Friedrich at uni-konstanz dot de Assigned:
Status: Closed Package: Apache related
PHP Version: 4.3.1 OS: Solaris 8
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: Joerg dot Dieter dot Friedrich at uni-konstanz dot de
New email:
PHP Version: OS:

 

 [2003-02-22 11:12 UTC] Joerg dot Dieter dot Friedrich at uni-konstanz dot de
Hi!

ATM I try to build PHP-Solaris-Packages. 
I use the INSTALL_ROOT feature of your Makefile.
The problem is that apxs is called with option -a to directly modify httpd.conf. But this is in a very different place.
Is is possible that '-a' is only appended to the apxs-call when INSTALL_ROOT is empty. 

Yours Joerg

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-22 23:51 UTC] sniper@php.net
I assume you have apache already installed under that INSTALL_ROOT ? In that case, IMO, we should make the install
to modify that httpd.conf instead..?

(I have fix for this ready..)

 [2003-02-23 01:36 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed May 05 20:01:23 2021 UTC