|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22376 wrong httpd.conf modified when using INSTALL_ROOT
Submitted: 2003-02-22 11:12 UTC Modified: 2003-02-23 01:36 UTC
From: Joerg dot Dieter dot Friedrich at uni-konstanz dot de Assigned:
Status: Closed Package: Apache related
PHP Version: 4.3.1 OS: Solaris 8
Private report: No CVE-ID:
 [2003-02-22 11:12 UTC] Joerg dot Dieter dot Friedrich at uni-konstanz dot de

ATM I try to build PHP-Solaris-Packages. 
I use the INSTALL_ROOT feature of your Makefile.
The problem is that apxs is called with option -a to directly modify httpd.conf. But this is in a very different place.
Is is possible that '-a' is only appended to the apxs-call when INSTALL_ROOT is empty. 

Yours Joerg


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-22 23:51 UTC]
I assume you have apache already installed under that INSTALL_ROOT ? In that case, IMO, we should make the install
to modify that httpd.conf instead..?

(I have fix for this ready..)

 [2003-02-23 01:36 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Mon Nov 30 06:01:32 2015 UTC