php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22322 Shared extentions not loaded
Submitted: 2003-02-20 04:17 UTC Modified: 2003-02-20 08:06 UTC
From: web at riscom dot net Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.3.1 OS: OpenBSD 3.2
Private report: No CVE-ID: None
 [2003-02-20 04:17 UTC] web at riscom dot net
i compiled php with all extenstion=shared
and got error, when apache start:
Unknown(): Invalid library (maybe not a PHP library)

it happends with all extension i've compiled php (mysql,gd,snmp...etc)

After reading README.SELF-CONTAINED-EXTENSIONS
i saw 
#ifdef COMPILE_DL_FOO
 ZEND_GET_MODULE(foo)
#endif

i found this lines in mysql.c extension but it doesnot work.
i put these 3 lines on the TOP of mysql.c
and this extension loaded successful!!

so is this right solution ? and why these 3 lines of code are in the middle of file ?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-20 07:31 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Ask these questions on the appropriate mailing list.

 [2003-02-20 08:06 UTC] web at riscom dot net
it is bug. because after i fix it all works perfect.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 17 11:01:31 2024 UTC