php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22292 PHP.EXE never ends
Submitted: 2003-02-19 03:34 UTC Modified: 2003-02-23 22:14 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: francois dot kaufmann at swisscom dot com Assigned:
Status: Not a bug Package: CGI/CLI related
PHP Version: 4.3.1 OS: WIN NT 4 SP6
Private report: No CVE-ID: None
 [2003-02-19 03:34 UTC] francois dot kaufmann at swisscom dot com
Hi,

I just installed PHP 4.3.1 (old used version was 4.0.6) and every time I call a sript, the PHP.EXE does'nt end! After a few calls, there are a lots of PHP.EXE running...

kaf

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-19 03:45 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2003-02-19 03:52 UTC] francois dot kaufmann at swisscom dot com
While executing a simple script:
<? echo "Hello wolrd!"; ?>

The IE browser (http://MyWeb/foo.php) displays the content of the script and remains working.

The Task Manager of the Web server shows one instance of PHP.EXE.

Trying to call the page on a second IE, the will be a second PHP.EXE running and so on until no more memory...

My understanding was that "<?" start an PHP.EXE instance and "?>" kills it.
 [2003-02-19 04:12 UTC] sniper@php.net
What web server?

 [2003-02-19 04:16 UTC] francois dot kaufmann at swisscom dot com
IIS 4
 [2003-02-19 04:20 UTC] sniper@php.net
Does this happen if your run php.exe on command line?

 [2003-02-19 04:25 UTC] v dot robert at ouestfrance-multimedia dot com
I've the same problem with NT4sp6a / IIS.

When using command line, i've drwatson: access violation ...

But when using ISAPI, all work fine !

thanks to see post: http://bugs.php.net/?id=22291&edit=1
 [2003-02-19 04:28 UTC] v dot robert at ouestfrance-multimedia dot com

 [2003-02-19 04:38 UTC] v dot robert at ouestfrance-multimedia dot com
I've just tried to execute my script: <? phpinfo(); ?> with command line (php.exe toto.php) on another server with php release 4.2.3 and all work fine.

So it's not a bug ???
 [2003-02-19 04:54 UTC] v dot robert at ouestfrance-multimedia dot com
When using command line, if extension=php_iisfunc.dll is on, i've an error, but when it's off (in comment), i've NO error.
 [2003-02-19 04:56 UTC] francois dot kaufmann at swisscom dot com
I had the exactly same sympton as described below while starting the script on command line (Dr. Watson)

Now as suggested I change the config to use ISAPI inteed of CGI and it works :-)

The only concern is that IASPI is not yet considered as to be production quality!

Anyway, thanks the the help
kaf
 [2003-02-19 06:52 UTC] cg at gordimer dot net
IMHO this should not be closed as the bug still exists (verified here too with IIS4/NT4).

Christoph
 [2003-02-19 07:10 UTC] v dot robert at ouestfrance-multimedia dot com
Why have you closed the subject ? The bug is still here. We can't use the command line and the CGI !!

We need some explanations !
 [2003-02-19 07:15 UTC] francois dot kaufmann at swisscom dot com
Excusez-moi!

I'm sorry, I rode the reply below wich says it is not a bug!
But the fellow tryied it with 4.2.3 and we are talking from 4.3.1....

It's open again
kaf
 [2003-02-19 12:59 UTC] shane@php.net
kaf,
Are you using the iisfunc.dll extension?  If so, please comment it out, and see if you still have the problem with php not ending.  If not, let us know. 

 [2003-02-21 02:06 UTC] francois dot kaufmann at swisscom dot com
Hi,

Since we could'nt come back on the first server, we use it, I did the test on another server wich has 'little' different config (Win2000 SP2, IIS 5) and there is the same symptom.
So I comment iisfunc.dll out and Yes, it works! PHP.EXE stops after serving the page....

kaf
 [2003-02-23 20:37 UTC] shane@php.net
Ok, this is a duplicate of bug 22291, the bug is in iisfunc.dll.  I'm closing this bug, refer to 22291 for this issue.
 [2003-02-23 22:14 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See bug #22291

 [2003-07-11 04:53 UTC] jouanneau at netcourrier dot com
I've got same problem, but php_iisfunc.dll extension is off !
NT4 + IIS4 + PHP 4.3.1 (CGI) + php_sybase_ct.dll
In fact, i discover that :

- in a php page, i've got a big sql query, so it take many time to display the result in my browser. During this time, the php.exe process take 0% of consuming time of CPU, and the sqlsrvr.exe process (sybase) take x% of CPU (well, it execute the query).

- if i click on the stop button in my browser, then the php.exe process take all CPU (90-100% !), and the sqlsrvr.exe only 0%. And the  php.exe process never ends.
- if i don't click on the stop button, after long time (because of big query), i've got the result in my page, and the process php.exe stop. 
Yes, i know it's bad to have a big query like this, but it's not the problem here, and i have optimized it after discovering this problem of no end of php.exe process. This problem of no end is still here..

hope that information can help developper to resolv this bug ..
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC