|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22248 Compile failed with php cgi / snmp
Submitted: 2003-02-17 07:06 UTC Modified: 2003-03-09 18:55 UTC
From: simon at dnadogs dot com Assigned:
Status: No Feedback Package: SNMP related
PHP Version: 4CVS-2003-02-17 (stable) OS: Solaris 8
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-02-17 07:06 UTC] simon at dnadogs dot com
I have compiled php with snmp support as a apache module with no problems but when I try to compile as cgi to be able to run scripts at command line i get the following error.

/usr/local/sparc-sun-solaris2.8/bin/ld: bfd assertion fail elflink.h:3542
I have cut down the configure command to just include snmp and mysql,  if i remove snmp it works.

I have installed the binary UCD SNMP for solaris from the official site.

All snmp functions work within the php / apache module.

Any help would be appreciated.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-17 10:50 UTC]
What is the ucd snmp version?
And are you absolutely sure it's not some problem
with that binary? Have you tried compiling it yourself
from sources??

 [2003-02-18 02:31 UTC] simon at dnadogs dot com
I am running UCD-SNMP 5.07,  I have now compiled and installed snmp from source and I still have the same problem.

The  apache php module will compile and work,  the cgi wont.
It looks like its compile everything ok then the final linking fails
 [2003-02-18 03:33 UTC] simon at dnadogs dot com
Further info.

A php binary is created in sapi/cgi/ and when i use it with a phpinfo() it says that snmp is enabled but if I try to use snmp functions i get they dont exist as follows -

php snmp.php 

Fatal error: Call to undefined function:  snmpget() in /users/downloads/Apache/php4-STABLE-200302171030/sapi/cgi/snmp.php on line 2
/users/downloads/Apache/php4-STABLE-200302171030/sapi/cgi/snmp.php(2) : Fatal error - Call to undefined function:  snmpget()
 [2003-02-18 23:28 UTC]
Can you please try the latest STABLE snapshot?
It has a sanity test for ext/snmp compile in configure
and it would be nice to know if it fails for you
when you configure/compile PHP as CGI.

Also, add the configure lines you have used for
configuring net-snmp and php.

 [2003-02-21 04:12 UTC] simon at dnadogs dot com

tried the latest snapshop and it compiles ok but has no snmp support in the binary.

errors with snmpget function not available.
 [2003-02-21 04:40 UTC]
That's pretty impossible as the configure would fail
if the snmp config fails.

Is 'HAVE_SNMP' defined in main/php_config.h ?

Does the sapi/cli/php binary have the functions?

 [2003-02-21 07:41 UTC] simon at dnadogs dot com
I did a make distclean then 

configure --with-snmp --with-mysql=/usr/local

and then make
still got 
/usr/local/sparc-sun-solaris2.8/bin/ld: bfd assertion fail elflink.h:3542

this was useing latest snapshot
 [2003-03-04 20:22 UTC]
Please check this out:

 [2003-03-09 18:55 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Apr 19 03:01:27 2024 UTC