php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2220 dynamic module memory leaks cause SIGSEGV under DEBUG mode
Submitted: 1999-09-02 12:33 UTC Modified: 2002-07-07 21:52 UTC
From: j at kubs dot cz Assigned: zeev (profile)
Status: Wont fix Package: Dynamic loading
PHP Version: 4.0 Latest CVS (02/09/1999) OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: j at kubs dot cz
New email:
PHP Version: OS:

 

 [1999-09-02 12:33 UTC] j at kubs dot cz
when a dynamic module leaves memory leaks and ZEND_DEBUG
is enabled, zend crashes while trying to write "memory leak at...", becouse filename pointer no longer points to a valid
area of memory after the module is unloaded. what'bout redefining emalloc to _emalloc(...,__LINE__,__FILE__) only
if COMPILE_DL is not defined?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-23 00:41 UTC] zak at cvs dot php dot net
Contacted Zeev on 00-08-22
 [2000-07-23 22:11 UTC] zak at cvs dot php dot net
Information from Zeev / 2000-07-23:
"We have no fix for this bug at this time.  It's not too urgent, as it only affects DEBUG builds."
 [2000-11-27 05:41 UTC] sniper@php.net
reclassify
 [2001-05-11 08:05 UTC] derick@php.net
Does this bug still exists with the latest release? (php 4.0.5)?
 [2001-05-14 02:42 UTC] j at kubs dot cz
i'm not involved in PHP development anymore. i can test it for you in a week. but a quick glance at the newest source hints me, it does.
 [2001-05-14 11:39 UTC] zeev@php.net
There haven't been any changes, so there's no need to test it in 4.0.5.  The problem is still there.

Updated the description to reflect it only occurs in debug mode.
 [2001-06-27 13:52 UTC] sniper@php.net
it's still Zeev's problem. :)

 [2001-09-22 11:34 UTC] derick@php.net
Anything new news on this?

Derick
 [2001-12-12 14:23 UTC] zak@php.net
Ping! Anything going on here?

 [2002-06-18 03:44 UTC] derick@php.net
Let's suspend this... are there won't be a fix for this.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 12:01:23 2020 UTC