php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22187 Error in number_format
Submitted: 2003-02-12 08:26 UTC Modified: 2003-02-12 14:46 UTC
From: php-bugreport at lippe-net dot de Assigned: iliaa
Status: Closed Package: Reproducible crash
PHP Version: 4CVS-2003-02-12 (stable) OS: Linux SuSE 8.1
Private report: No CVE-ID:
 [2003-02-12 08:26 UTC] php-bugreport at lippe-net dot de
Process crashes in PHP Version 4.3.1-dev when this code is executed:

<?PHP
echo "This line isn't shown, when using with PHP Version 4.3.1-dev, because of the following line ... :-)";
echo number_format (0.001, 1);
?>

Log:
[Wed Feb 12 16:27:56 2003] [notice] child pid 18557 exit signal Segmentation fault (11)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-12 14:46 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 06:02:27 2014 UTC