php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22101 Wrong behaviour of open_basedir restriction
Submitted: 2003-02-06 19:58 UTC Modified: 2005-01-31 22:42 UTC
Votes:4
Avg. Score:4.8 ± 0.4
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:2 (50.0%)
From: cmouse at quakenet dot org Assigned:
Status: Not a bug Package: Safe Mode/open_basedir
PHP Version: 4.3.0 OS: Debian linux 2.4.19
Private report: No CVE-ID:
 [2003-02-06 19:58 UTC] cmouse at quakenet dot org
Warning: Unknown(): open_basedir restriction in effect. File(/www/htdocs/phpSysInfo-2.1/index.php) is not within the allowed path(s): (/) in Unknown on line 0

Warning: Unknown(/www/htdocs/phpSysInfo-2.1/index.php): failed to create stream: Operation not permitted in Unknown on line 0

Warning: Unknown(): Failed opening '/www/htdocs/phpSysInfo-2.1/index.php' for inclusion (include_path='.:/usr/lib/php') in Unknown on line 0

As you can see, /www is in my opinion, inside /, which is my open_basedir for this particular file. 

The Apache config for this directory:

<Directory "/www/htdocs/phpSysInfo-2.1">
 php_admin_value open_basedir "/"
</Directory>

You can get the phpSysInfo-2.1 script yourselves, too long to paste here, and it's not mine anyways.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-06 20:27 UTC] rasmus@php.net
I wouldn't be surprised if an open_basedir set to / wasn't handled correctly.  It is one of these non-sensical settings that I suppose we should account for, but it really is meaningless.  All you are doing is burning more system calls with absolutely no benefit since everything is under /
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 21:01:55 2014 UTC