php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22072 connection_status() always returning 0
Submitted: 2003-02-05 09:05 UTC Modified: 2003-08-01 15:21 UTC
Votes:13
Avg. Score:4.9 ± 0.3
Reproduced:12 of 12 (100.0%)
Same Version:6 (50.0%)
Same OS:2 (16.7%)
From: neil at mpfreescene dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.3.2 OS: FREEBSD 4.7-STABLE
Private report: No CVE-ID:
 [2003-02-05 09:05 UTC] neil at mpfreescene dot com
This bug is effecting the connection_status() function in apache 2.x

Okay, getting back to a long standing bug, which we kind of come to the conclusion last time that it may be a bug in apache 2.x because it works in apache 1.

Well time has come on, I have submitted the bug to apache after they fixed the incorrect bytes logged bug, and this is what they have come up with :-

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16426

ok, I've grabbed the current php source and looked into sapi_apache2.c. It's
definitely a php bug. Line 90 shows:

if (ap_pass_brigade(f->next, bb) != APR_SUCCESS) {
php_handle_aborted_connection();
}

which won't match in most cases. Also Line 252 and 498.
AFAICS mod_php should (additionally) check connection->aborted.

(marking this bug invalid again)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-06 04:36 UTC] neil at mpfreescene dot com
To further assist you in your diagnosis, I have supplied you with additional parameters to the script that is failing.


Firstly you can run the script

http://www.mpfreescene.com/test/

Secondly you can see the source

http://www.mpfreescene.com/test/?option=source

Thirdly you can see phpinfo

http://www.mpfreescene.com/test/?option=info

Forthly you can see the output.txt file, i.e. the result of the failing script :-

http://www.mpfreescene.com/test/?option=data




Just to recap, this identical script works fine on apache 1,  I have been to apache they are pushing it back as an php error [the error they found in an apache2 specific library maybe ?].  And the problem is I run the script, whenI press stop, it continues to run in the background and completes normally, i.e. it doesnt recogonise the user abort.



Thanks for your help in this matteer.
 [2003-02-19 10:48 UTC] jorgeg at gtsf dot com
Hope this helps. Two other functions affected:
ignore_user_abort(), connection_aborted()

The first one is useless, it keeps running the script regardless the param has been set to true or false. The second one is always 0.

Apache 2.0.44, PHP 4.3.0, Windows 2k
 [2003-07-24 03:35 UTC] neil at mpfreescene dot com
Does PHP 5 include this bug, will this ever get fixed ?
 [2003-08-01 12:55 UTC] neil at mpfreescene dot com
Test the new CVS, it is still doing the same.
 [2003-08-01 15:21 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 00:01:21 2014 UTC