php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22033 Kryptic errors when not using "portability" option in DB
Submitted: 2003-02-03 10:34 UTC Modified: 2003-04-27 16:17 UTC
From: stamer at uni-oldenburg dot de Assigned:
Status: Not a bug Package: PEAR related
PHP Version: 4.3.0 OS: Linux & Oracle
Private report: No CVE-ID: None
 [2003-02-03 10:34 UTC] stamer at uni-oldenburg dot de
Hi,
This is not really a bug, but it may take to too much time to
track the source of error.
I am using Linux with Oracle9. If I use e.g. DB_Result::numRows() without option set to "portability" 
(didn't know about it, first...), I get really kryptic
error messages, since an object is returned instead of an
expected integer. 
This yields then "Unsupported operand types" if you try to
subtract an integer, and one really does not know what is going on.

Greetings, Heinrich

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-27 16:17 UTC] lsmith@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

PEAR DB always returns error objects when errors occur.
Please see the manual for details, specifically:
http://pear.php.net/manual/en/core.db.iserror.php
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Mar 05 03:01:30 2024 UTC