php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21870 Core Predefinded with wrong paths
Submitted: 2003-01-24 18:50 UTC Modified: 2003-06-04 03:36 UTC
From: cg at gordimer dot net Assigned: ssb (profile)
Status: Closed Package: PEAR related
PHP Version: 4CVS-2003-01-24 (stable) OS: XP Pro
Private report: No CVE-ID: None
 [2003-01-24 18:50 UTC] cg at gordimer dot net
The following predefined constants do not reflect the settings on my ws (all PHP is on E:\ and F:\):

    [PEAR_INSTALL_DIR] => c:\php4\pear
    [PEAR_EXTENSION_DIR] => c:\php4
    [PHP_EXTENSION_DIR] => c:\php4
    [PHP_PREFIX] => c:\php4
    [PHP_BINDIR] => c:\php4
    [PHP_LIBDIR] => c:\php4
    [PHP_DATADIR] => c:\php4
    [PHP_SYSCONFDIR] => c:\php4
    [PHP_LOCALSTATEDIR] => c:\php4
    [PHP_CONFIG_FILE_PATH] => C:\

Maybe this is the cause for PEAR install problems on Windows (see http://bugs.php.net#21558,http://bugs.php.net/21787 and some recent messages on pear-general and pear-dev) - anyway, they're not correctly defined and make IMHO no sense if they aren't.

Christoph

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-13 00:50 UTC] sniper@php.net
reclassified and assigned to Stig who should know what to do with this :)

 [2003-06-04 03:36 UTC] pajoye@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

Another ENV variables system has been added. 
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 08:03:36 2021 UTC