php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21825 Fatal error: Nesting level too deep
Submitted: 2003-01-22 14:31 UTC Modified: 2003-01-22 15:45 UTC
From: rhornsby at osuedc dot org Assigned:
Status: Closed Package: Reproducible crash
PHP Version: 4.3.0 OS: Linux 2.4.19
Private report: No CVE-ID: None
 [2003-01-22 14:31 UTC] rhornsby at osuedc dot org
This error occurs at the bottom of every PHP-parsed page:

"Fatal error: Nesting level too deep - recursive dependency? in Unknown on line 0"

The pages seem to render okay, but the error appears to end each page.  It even spit out the same error dozens of times on make test, and after sending in the test results.

./configure  --with-apxs=/usr/local/apache/bin/apxs  
 --enable-trans-sid
 --enable-track-vars
 --with-gd
 --with-pdflib
 --with-jpeg-dir  
 --with-tiff-dir
 --with-pspell
 --with-freetype-dir
 --enable-gd-native-ttf
 --with-png-dir 
 --with-zlib-dir
 --with-ttf
 --with-mysql=/usr/local/mysql

The system is MDK9 and Apache 1.3.26

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-22 15:04 UTC] michael dot mauch at gmx dot de
Can you please find the extension_dir setting in your php.ini and make sure that it points to the directory with your newly built modules? There have been reports where this "Nesting level too deep" was caused by an extension_dir that pointed to the modules of a previous PHP installation.
 [2003-01-22 15:45 UTC] rhornsby at osuedc dot org
Strange, but pointing extension_dir to /usr/local/lib/php/extension (which doesn't seem to contain anything useful) as opposed to /usr/lib/php/extensions seems to have fixed the issue.

I saw those other reports, but had compiled (or I thought) 4.3.0 successfully before.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 03:01:23 2019 UTC