php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21802 unexpected T_WHITESPACE
Submitted: 2003-01-21 12:45 UTC Modified: 2004-12-30 16:24 UTC
Votes:12
Avg. Score:4.2 ± 0.7
Reproduced:11 of 11 (100.0%)
Same Version:0 (0.0%)
Same OS:6 (54.5%)
From: gmourani at openna dot com Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.3.0 OS: OpenNA Linux
Private report: No CVE-ID:
 [2003-01-21 12:45 UTC] gmourani at openna dot com
Compiling PHP 4.3.0 with Pear support fail to install and return the following message:

Parse error: syntax error, unexpected T_WHITESPACE in /usr/src/openna/BUILD/php-4.3.0/pear/install-pear.php on line 3
make[1]: *** [install-pear-installer] Error 255
make: *** [install-pear] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.19931 (%install)

Configure line is as follow:
%configure \
        --prefix=%{_prefix} \
        --with-layout=GNU \
        --with-config-file-path=%{_sysconfdir}/httpd \
        --enable-force-cgi-redirect \
        --with-apxs2=%{_sbindir}/apxs \
        --with-exec-dir=%{_bindir} \
        --with-openssl \
        --with-zlib \
        --with-bz2 \
        --with-gd \
        --with-ttf \
        --with-png \
        --with-jpeg-dir=%{_prefix} \
        --with-png-dir=%{_prefix} \
        --with-freetype-dir=%{_prefix} \
        --with-expat-dir=%{_prefix} \
        --with-gmp \
        --with-xml \
        --with-curl \
        --with-mm \
        --with-pear=%{_datadir}/pear \
        --with-imap=shared \
        --with-imap-ssl \
        --with-mysql=shared,%{_prefix} \
        --with-mysql-sock=/var/lib/mysql/mysql.sock \
        --with-pgsql=shared \
        --with-ldap=shared \
        --disable-static \
        --disable-debug \
        --disable-rpath \
        --disable-posix \
        --disable-tokenizer \
        --enable-discard-path \
        --enable-safe-mode \
        --enable-magic-quotes \
        --enable-bcmath \
        --enable-dio \
        --enable-gd-native-ttf \
        --enable-sysvsem \
        --enable-sysvshm \
        --enable-track-vars \
        --enable-wddx \
        --enable-inline-optimization \
        --enable-memory-limit

G

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-08 09:17 UTC] alan_k@php.net
so what do the first 4 lins of install-pear.php look like?

/usr/src/openna/BUILD/php-4.3.0/pear/install-pear.php on line 3

can you try 4.3.1 see if that helps?
 [2003-03-19 16:48 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-03-30 02:08 UTC] thomas dot lamy at in-online dot net
Same problem here, with debian/sarge and php-4.3.1.

I really don't have a clue, but suspect sablotron or expat to cause this.
I use ablotron (0.9.7) and expat (1.95.6), and the debian-scripts from the deb package maintainer.

configure:
                --enable-memory-limit \
                --enable-calendar \
                --enable-sysvsem \
                --enable-sysvshm \
                --enable-track-vars \
                --enable-trans-sid \
                --enable-bcmath \
                --with-bz2 \
                --enable-ctype \
                --with-db2 \
                --with-iconv \
                --with-gdbm \
                --enable-exif \
                --enable-filepro \
                --enable-ftp \
                --with-gettext \
                --enable-mbstring \
                --with-pcre-regex=/usr \
                --enable-shmop \
                --enable-sockets \
                --enable-wddx \
                --with-xml=/usr --with-expat-dir=/usr \
                --enable-yp \
                --with-zlib \
                --without-pgsql
 [2003-04-03 01:02 UTC] thomas dot lamy at in-online dot net
Seems like this bug is introduced when re-building Zend/zend_language_scanner.c with flex. Try to build again from fresh source, and with proper date/time on the build host.
 [2003-07-10 02:07 UTC] 5689103753 at ma-scha dot de
I get the same bug with bison 1.875.
I installed bison 1.28 and all works fine again.

Try to look at the first lines of output from
the configure script it shows you what version it needs,
but it doesn't stop on a wrong version.
 [2003-07-10 04:26 UTC] cox@php.net
Re-classified to the proper category
 [2004-03-31 02:09 UTC] monk at farpost dot com
Some error with php-4.3.5 and bison-1.875
Fixed by installing bison-1.35
 [2004-06-25 14:33 UTC] mandreiana at yahoo dot com
Fedora SRPM has this:

# bison-1.875-2 seems to produce a broken parser; workaround.
mkdir Zend && cp ../Zend/zend_{language,ini}_parser.[ch] Zend
 [2004-06-25 22:35 UTC] eggert at gnu dot org
Please see the patch in the PHP bug 28930 description. I think this patch will fix bug 21802.
 [2004-10-06 09:17 UTC] jpmarroquin at mail dot com
I'm getting the same error but with PHP 5.0.2!!!
This is on Mandrake 10.0, Apache 1.3.31
 [2004-12-30 16:24 UTC] sniper@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Mon Apr 21 07:02:06 2014 UTC