php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21787 go-pear/installer using relative paths?
Submitted: 2003-01-20 19:23 UTC Modified: 2003-05-21 20:10 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: danielc at analysisandsolutions dot com Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.2RC1 OS: Windows NT 4.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: danielc at analysisandsolutions dot com
New email:
PHP Version: OS:

 

 [2003-01-20 19:23 UTC] danielc at analysisandsolutions dot com
Hi:

Installing PEAR via go-pear winds up splitting the installation between two drives.  It seems the installer program specifies a relative path rather than a full path.

Here's what I did.

f:cli\php -n -r "include 'http://go-pear.org';"

I go along with all of the defaults.

I wind up getting two php4\pear directories.  One is c:\php4\pear, which has the full .registry directory plus three blank directories: data, docs, tests.  The second is g:\php4\pear, which contains the main files, such as Db.php, Mail.php, etc.

I suspect the installation has wound up there because my TEMP dir is on the G drive.

I've tried several incantations, but all wind up doing basically the same thing...

Thanks,

--Dan

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-26 14:02 UTC] danielc at analysisandsolutions dot com
This definitely has to do with the TEMP and/or TMP environment variable.

I've built a new system.  Windows 2000.  PHP 4.3.1.  go-pear.php v 1.34.

The user TMP and TEMP variables are set to a directory on the D: drive.  Running go-pear.php similarly split the installation between the drive I designated and the temp drive.

To further confirm this hypothesis, I removed the user environment variables, leaving the system TMP and TEMP variables which lead to a directory on the C: drive.  Rerunning go-pear.php produced things going to the right drive.
 [2003-03-26 16:04 UTC] stone@php.net
verified with 4.3.2 RC1 on NT and XP PRO
 [2003-03-27 06:34 UTC] edink@php.net
Concetrating all PEAR@win32 install problems in #21619. Closing this one.
 [2003-03-27 11:24 UTC] danielc at analysisandsolutions dot com
Considering this is a verified bug and you're consolidating the activity to a different bug report, the appropiate status is "Duplicate."
 [2003-05-21 20:10 UTC] sniper@php.net
Bug #21619 is closed, closing this too.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 17:03:14 2021 UTC