php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21619 go-pear fails to install "pear/scripts" directory
Submitted: 2003-01-13 11:33 UTC Modified: 2004-10-14 14:51 UTC
Votes:6
Avg. Score:4.8 ± 0.4
Reproduced:6 of 6 (100.0%)
Same Version:5 (83.3%)
Same OS:6 (100.0%)
From: michele dot manzato at verona dot miz dot it Assigned: pajoye (profile)
Status: Closed Package: PEAR related
PHP Version: 4.3.2Rc1 OS: Win32
Private report: No CVE-ID: None
 [2003-01-13 11:33 UTC] michele dot manzato at verona dot miz dot it
Installing PEAR from scratch using the "go-pear" feature ends up in an unusable pear.bat utility  since the "pear/scripts" directory (containing the required "pear.in" file) is not installed.

Workaround: copy from ZIP installation. But this won't do in 4.3.0 since pear isn't shipped even in the ZIP.

Hope this was not submitted before.

Regards
Michele

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-14 10:05 UTC] christian at nospam dot spam
problem still exists in 4.3.1 and 4.3.2RC1 under Windows. :-(
 [2003-03-18 09:48 UTC] T dot Haas at Xardal dot de
I Work with Windows 2000. My pear.bat can't find some pathes and doesn't work too. I guess my problem is the same problem as noticed.
 [2003-03-19 13:14 UTC] jacobhanson at firsthealth dot com
Verified same behaviour on WinXP SP1 w/4.3.2rc1. :[
 [2003-03-21 22:16 UTC] alan_k@php.net
confirmed - this is release critical for pear.



totaly clean install:
cd C:/php4
go-pear
.... start process - gets to installing packages..
.. stops failing to make directory c://php4// (something)

go-pear (again)
goes all the way through.

- failed to install pearwin.php
- pear.bat has unix line breaks - rendering it impossible to run
 [2003-03-21 22:18 UTC] alan at akbkhome dot com
workaround download http://cvs.php.net/co.php/php4/pear/scripts/pearwin.php?login=2&r=1.10
put it in the php4 directory
and modify the pear.bat script (in wordpad - save as dos file)
to point to it.
 [2003-03-21 22:45 UTC] alan at akbkhome dot com
Workaround.
ignore the comment about pearwin.php - it's an old file?
put this in the php4 directory
http://cvs.php.net/co.php/php4/pear/scripts/pear.in?login=2&r=1.67
modify the pear.bat to point to it.

modify the pear.in file and change the @include_path@ etc. to 
the correct locations.
 [2003-03-25 08:34 UTC] mj@php.net
Could you please test http://pear.php.net/~mj/go-pear (cli\php -n -r "include 'http://pear.php.net/~mj/go-pear'")?

This version works for me on Windows 2000.
 [2003-03-25 09:47 UTC] edink@php.net
Nope. Still no sign og pear.bat. And the packages get installed in c:\php4 instead of c:\php4\pear. Another side-effect is that package .tgz files get left in the c:\php4 dir.
 [2003-03-25 09:52 UTC] michele dot manzato at verona dot miz dot it
It doesn't work for me (PHP 4.3.1). Problems:

1) bootstrap command should terminate in ';':
cli\php -n -r "include 'http://pear.php.net/~mj/go-pear';"

2) go-pear default installation prefix is empty. Should be 'c:\php' (at least).

3) go-pear complains about include_path being '.;c:\php4\includes'. I think it's because of the leading '-n' in the go-pear bootstrap command that force ignore of 'php.ini'. BTW php folks should fix this weird setting sometime... (http://bugs.php.net/bug.php?id=21609)

4) 'c:\php\pear\scripts' was still not installed.

5) Running pear.bat as it is installed cause silent failure (no output).

6) the installed pear.bat contained:

   set PHP_BIN=c:\php\php.exe
   set BIN_DIR=c:\php
   set PEAR_PATH=.;c:\php4\pear

   %PHP_BIN% -C -d output_buffering=1 -d include_path=%PEAR_PATH% -f %BIN_DIR%\pear -- %1 %2 %3 %4 %5 %6 %7 %8 %9

The parameter to -f is meaningless according to the installation.

Hope this helps
Michele
 [2003-03-25 16:10 UTC] cg at gordimer dot net
Here it doesn't work either, trying to install on another drive:
Some files/directories are created in the destination drive (f:): pear/.registry, pear/data pear/docs, pear/tests

Some other files/directories are created in a parallel directory structure on c\: pear.bat, .tmppear, and the pear directory with the classes.

The installed pear.bat contained:
set PHP_BIN=@php_bin@
set BIN_DIR=@bin_dir@
set PEAR_PATH=@include_path@ 

This was on XP Pro. On NT4 almost the same, but there the directory structure was ok because PEAR was installed on the c:\ drive. 

Maybe you'll have a look at http://bugs.php.net?17516. I think that's the cause for the wrong default paths. The script should at least look for a php.ini in the directory where it's called from because the ini file is often there.

Christoph
 [2003-03-28 04:19 UTC] urs@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

Could you please test the Windows optimized go-pear:

C:\php>cli\php -n -r "include('http://circle.ch/go-pear');"

It works now for me on Windows 2000. I changed the tmp directory creation. Christoph (stone@php.net) and I were discussing go-pear yesterday.

-urs
 [2003-03-28 07:03 UTC] edink@php.net
Sorry but this still does not work on my win2k machine. I get nothing except empty pear dir with the 3 subfolders and a bogus afterinstall message:

The 'pear' command is now at your service at

** The 'pear' command is not currently in your PATH, so you need to
** use '' until you have added
** 'C:\php4' to your PATH environment variable.

And c:\php4 is actually in my path.
 [2003-03-28 07:07 UTC] edink@php.net
Hm, I have just discovered that PEAR was installed in c:\tmp\gp for some reason.

pear.bat in c:\tmp\gp\scripts has the following:

set PHP_BIN=c:\php4\php.exe
set PEAR_PATH=c:\tmp\gp

IMHO pear.bat and pear.in should be placed in the
${Installation prefix} and not ${}Installation prefix\scripts.
 [2003-04-26 11:58 UTC] pajoye@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

Fixed in the current go-pear.

Try go-pear from the php4 snapshot using the bundled packages.

thank's

pierre
 [2004-10-14 13:29 UTC] abiale at sgh dot waw dot pl
Could you help me?

I run apache 2.0/php 4. on WinNT.

I`d like to install pear. I ran go-pear.bat, I got some tar gz files, but I don`t know how to go on. 

The installation trough the web stops at:
Undefined class name 'pear' in go-pear.php on line 645

Artur
 [2004-10-14 14:26 UTC] michele dot manzato at verona dot miz dot it
Actually the go-pear support works quite well both on Linux and Win32 since 4.3.something. I haven't run into similar problems recently. 

Just make sure you have:
- a recent PHP installed, upgraded with all the files that you found in the .zip version. The .msi installer does not provide a complete installation at all, I wonder why the PHP team decided so.
- a reasonable set PHP of extensions enabled (at least php_xml and php_curl, if I remember well). Remember that some works only if you copy the DLLs in the dll directory into WINNT/system32

Bye
Michele
 [2004-10-14 14:51 UTC] thesaur@php.net
Note: You don't need to put the php extensions in Windows\System32. Instead, change the setting in your php.ini file to point to your php\ext directory or wherever you prefer keeping the extensions. Will make it much easier to upgrade and will prevent you from accidentally causing dll bloat.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Oct 22 16:01:28 2019 UTC