php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21777 Libtool error and apache segmentation fault when load libphp4.so
Submitted: 2003-01-20 10:47 UTC Modified: 2003-01-20 21:03 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: jperezme at mi dot madritel dot es Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.3.0 OS: Aix 4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
47 - 26 = ?
Subscribe to this entry?

 
 [2003-01-20 10:47 UTC] jperezme at mi dot madritel dot es
I have apache 2.0.43 working on Aix 4.3.3.10. When i try build php4-latest,4.3.0, 4.2.3 or 4.2.2 all go fine except, on make install process and if i continue, when apache load module libphp4.so doesn't start and show a segmentation fault error.I use gcc-3.2.1 and gnu.make.
-----------------------------------------------------------
# setenv CC /usr/local/bin/gcc
#./configure --enable-force-cgi-redirect \
                 --enable-static --disable-shared \
                 --with-mysql --with-apxs2=/usr/IBMIHS/bin/apxs \
--prefix=/usr/IBMIHS/php --with-config-file-path=/usr/IBMIHS/php

------------------------------------------------------------
Appear this error, although i continuous:

creating main/internal_functions_cli.c
+--------------------------------------------------------------------+
|                        *** WARNING ***                             |
|                                                                    |
| You chose to compile PHP with the built-in MySQL support.  If you  |
| are compiling a server module, and intend to use other server      |
| modules that also use MySQL (e.g, mod_auth_mysql, PHP 3.0,         |
| mod_perl) you must NOT rely on PHP's built-in MySQL support, and   |
| instead build it with your local MySQL support files, by adding    |
| --with-mysql=/path/to/mysql to your configure line.                |
+--------------------------------------------------------------------+
| License:                                                           |
| This software is subject to the PHP License, available in this     |
| distribution in the file LICENSE.  By continuing this installation |
| process, you are bound by the terms of this license agreement.     |
| If you do not agree with the terms of this license, you must abort |
| the installation process at this point.                            |
+--------------------------------------------------------------------+
|                          *** NOTE ***                              |
|            The default for register_globals is now OFF!            |
|                                                                    |
| If your application relies on register_globals being ON, you       |
| should explicitly set it to on in your php.ini file.               |
| Note that you are strongly encouraged to read                      |
| http://www.php.net/manual/en/security.registerglobals.php          |
| about the implications of having register_globals set to on, and   |
| avoid using it if possible.                                        |
+--------------------------------------------------------------------+

./config.status[1814]: 6: bad file unit number
./config.status[1815]: 6: bad file unit number

-----------------------------------------------------------

#make
#make install
Installing PHP SAPI module
/usr/IBMIHS/build/instdso.sh SH_LIBTOOL='/usr/IBMIHS/build/libtool' libphp4.la /usr/IBMIHS/modules

/usr/IBMIHS/build/libtool --mode=install cp libphp4.la /usr/IBMIHS/modules/
cp .libs/libphp4.a /usr/IBMIHS/modules/libphp4.a
cp .libs/libphp4.lai /usr/IBMIHS/modules/libphp4.la
libtool: install: warning: remember to run `libtool --finish /software2/php-4.3.0/libs'
chmod 755 /usr/IBMIHS/modules/libphp4.so
chmod: /usr/IBMIHS/modules/libphp4.so: Un archivo o directorio en la v?a de acceso no existe.
apxs:Error: Command failed with rc=65536
.
make: 1254-004 El c?digo de error del ?ltimo mandato es 1.

-------------------------------------------------
At this point i cp .libs/libphp4.so /usr/IBMIHS/modules and i make install again.
-------------------------------------------------
#make install
Installing PHP SAPI module
/usr/IBMIHS/build/instdso.sh SH_LIBTOOL='/usr/IBMIHS/build/libtool' libphp4.la /usr/IBMIHS/modules

/usr/IBMIHS/build/libtool --mode=install cp libphp4.la /usr/IBMIHS/modules/
cp .libs/libphp4.a /usr/IBMIHS/modules/libphp4.a
cp .libs/libphp4.lai /usr/IBMIHS/modules/libphp4.la
libtool: install: warning: remember to run `libtool --finish /software2/php-4.3.0/libs'
chmod 755 /usr/IBMIHS/modules/libphp4.so
Installing shared extensions:     /usr/IBMIHS/php/lib/php/extensions/no-debug-zts-20020429/
Installing PEAR environment:      /usr/IBMIHS/php/lib/php/
[PEAR] Archive_Tar    - installed: 0.9
[PEAR] Console_Getopt - installed: 1.0
[PEAR] PEAR           - installed: 1.0b3
[PEAR] DB             - installed: 1.3
[PEAR] HTTP           - installed: 1.2
[PEAR] Mail           - installed: 1.0.1
[PEAR] Net_SMTP       - installed: 1.0
[PEAR] Net_Socket     - installed: 1.0.1
[PEAR] XML_Parser     - installed: 1.0
[PEAR] XML_RPC        - installed: 1.0.4
Installing build environment:     /usr/IBMIHS/php/lib/php/build/
Installing header files:          /usr/IBMIHS/php/include/php/
Installing helper programs:       /usr/IBMIHS/php/bin/
  program: phpize
  program: php-config
  program: phpextdist
El destino "install" is upgraded.

#cp php.ini-dist /usr/IBMIHS/php/php.ini

Then i start apache and shows segmentation fault.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-20 11:04 UTC] moriyoshi@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

And could you paste the result of the following command too? 

$ httpd -l

Anyway don't forget to recheck the manual page:
http://www.php.net/manual/en/install.apache2.php

 [2003-01-20 13:26 UTC] jperezme at mi dot madritel dot es
These are the results of gdb and httpd -l
#httpd -l
Compiled in modules:
  core.c
  worker.c
  http_core.c
  mod_suexec.c
  mod_so.c


#gdb /usr/IBMIHS/bin/httpd /usr/IBMIHS/bin/core              <
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "powerpc-ibm-aix4.3.2.0"...
(no debugging symbols found)...
Core was generated by `httpd'.
Program terminated with signal 11, Segmentation fault.
#0  0xd0fe04d4 in apr_palloc ()
(gdb) bt
#0  0xd0fe04d4 in apr_palloc ()
#1  0xd0fe0418 in create_php_config (p=0x200233c0, dummy=0x28 " ")
    at /software2/php-4.3.0/sapi/apache2filter/apache_config.c:212
#2  0x10004e54 in ap_single_module_configure ()
#3  0x10037098 in load_module ()
#4  0x100020f8 in invoke_cmd ()
#5  0x10001e80 in execute_now ()
#6  0x10001bb4 in ap_build_config_sub ()
#7  0x10004fb4 in ap_build_config ()
#8  0x10004134 in ap_process_resource_config ()
#9  0x10004ab0 in ap_read_config ()
#10 0x100009dc in main ()
#11 0x100001b4 in __start ()
(gdb)
 [2003-01-20 17:00 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

http://bugs.php.net/bug.php?id=14245

 [2003-01-20 19:45 UTC] jperezme at mi dot madritel dot es
Sorry, i read a lot of messages related to php and apache2, i recompiled one time and another time without diffrent parameters, but i think bug 14245 is different to my error. That bug is for different version of apache 2 and it think my error could be in bug of libtool because make install shows me:
 libtool: install: warning: remember to run `libtool --finish /software2/php-4.3.0/libs'

In my first message i described how little problems like copy libphp4.so manually to necesary directory on apache i did it(like bug 14245).
Excuse me if now i don't must add here this comment again.

Thanks.
 [2003-01-20 21:03 UTC] sniper@php.net
It doesn't matter what apache version is used, it's still
an AIX + Libtool problem.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 06:01:28 2024 UTC