php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14245 make install fails on apxs
Submitted: 2001-11-27 01:12 UTC Modified: 2003-02-25 00:43 UTC
Votes:24
Avg. Score:4.8 ± 0.6
Reproduced:23 of 23 (100.0%)
Same Version:8 (34.8%)
Same OS:15 (65.2%)
From: david-shafer at uiowa dot edu Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.3.0-dev OS: AIX 4.3.3
Private report: No CVE-ID:
 [2001-11-27 01:12 UTC] david-shafer at uiowa dot edu
Make install fails on "apxs -i i -a -n php4 libs/libphp4.so
cp libs/libphp4.so /local/www/libexec/libphp4.so". The libs directory contains libphp4.a and libphp4.la, but not libphp4.so.

Compiler: IBM Visual Age C

$ export CC="cc_r"
$ export CFLAGS="-g -ma"

$ ./configure --prefix=/local/www/php \
--with-apxs=/local/www/bin/apxs \
--without-mysql

$ make
Making all in Zend
...
Target "all" is up to date.

# /local/www/bin/apachectl stop

# /usr/sbin/slibclean

# make install
Making install in Zend
...
Target "install-p" is up to date.
Target "install" is up to date.
Making install in .
        /local/www/bin/apxs -i -a -n php4 libs/libphp4.so
cp libs/libphp4.so /local/www/libexec/libphp4.so
cp: libs/libphp4.so: A file or directory in the path name does not exist.
apxs:Break: Command failed with rc=65536
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
# ls -l libs
total 16008
-rw-------   1 root     system   4094311 Nov 26 23:53 libphp4.a
-rw-------   1 root     system       749 Nov 26 23:53 libphp4.la

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-28 13:55 UTC] david-shafer at uiowa dot edu
I've found a workaround for this problem. If I manually copy .libs/libphp4.so.0 to libs/libphp4.so, it seems to continue okay:

# make install
...
cp: libs/libphp4.so: A file or directory in the path name does not exist.
apxs:Break: Command failed with rc=65536
make: 1254-004 The error code from the last command is 1.
...
Stop.

# cp .libs/libphp4.so.0 libs/libphp4.so

# make install
...
Target "install-p" is up to date.
Target "install" is up to date.
Making install in .
        /local/www/bin/apxs -i -a -n php4 libs/libphp4.so
cp libs/libphp4.so /local/www/libexec/libphp4.so
chmod 755 /local/www/libexec/libphp4.so
[activating module `php4' in /local/www/conf/httpd.conf]
installing shared modules into /local/www/php/lib/php/20010901
Target "install-p" is up to date.
...
Target "install" is up to date.

# /local/www/bin/apachectl start
Target "install" is up to date.


Is there some way "make install" can do that copying step automatically?
 [2001-12-11 13:47 UTC] derick@php.net
This should be fixed in CVS< can you try a snapshot from snaps.php.net?

Derick
 [2001-12-12 11:05 UTC] sniper@php.net
This is NOT fixed in CVS yet. It's a libtool bug and I'm trying to find
out how to fix it atm.

 [2001-12-16 16:28 UTC] sniper@php.net
Don't have time to look at this anymore. And it indeed is a libtool bug.

 [2002-02-01 17:20 UTC] gene dot rowe dot lix3 at statefarm dot com
I am trying to install PHP 4.1.1 on AIX 4.3.3. I have GNU GCC 3.01 installed

$ ./configure --prefix=/usr/local/php \
--with-apxs \
--with-mysql \
--with-zlib

$ make
Making all in Zend
...
Target "all" is up to date.

# /local/www/bin/apachectl stop

# /usr/sbin/slibclean

# make install
Making install in Zend
...
Target "install-p" is up to date.
Target "install" is up to date.
Making install in .
        /local/www/bin/apxs -i -a -n php4 libs/libphp4.so
cp libs/libphp4.so /local/www/libexec/libphp4.so
cp: libs/libphp4.so: A file or directory in the path name does not
exist.
apxs:Break: Command failed with rc=65536
make: 1254-004 The error code from the last command is 1.

Stop.
make: 1254-004 The error code from the last command is 1.

Stop.
# ls -l libs
total 16008
-rw-------   1 root     system   4094311 Nov 26 23:53 libphp4.a
-rw-------   1 root     system       749 Nov 26 23:53 libphp4.la

Any update on resolution to this problem?? or a good workaround? I can not find lilphp4.so.0 as mentioned above.
 [2002-02-02 13:45 UTC] gene dot rowe dot lix3 at statefarm dot com
Just tried the latest release from the CVS and got the same results. libphp4.so is not being created.
 [2002-02-02 16:05 UTC] david-shafer at uiowa dot edu
Did you look for "libphp4.so.0" in the ".libs" directory? (Note the leading "."; it's a different directory than "libs")
 [2002-02-12 04:39 UTC] vervoom at hotmail dot com
Have you got a fix for this yet?
 [2002-07-11 04:38 UTC] derick@php.net
There were a lot of fixes done to the build system, the best way to check it is to try for yourself. I suggest you try the latest snapshot @ http://snaps.php.net/php4-latest.tar.gz

Derick
 [2002-07-11 11:23 UTC] sniper@php.net
This is not fixed. But we know what the problem is and hope
to get it solved for 4.3.0 release.

 [2002-09-30 17:12 UTC] steve at oseda dot missouri dot edu
Same problem.  AIX 4.3.3.10, GCC 2.95, PHP 4.2.3, Gnu Make 3.79

**************************************
Making install in .
make[1]: Entering directory `/oseda/php-4.2.3'
/oseda/php-4.2.3/build/shtool mkdir -p "/usr/local/apache/libexec" && /usr/local/apache/bin/apxs -S 

LIBEXECDIR="/usr/local/apache/libexec" -i -a -n php4 libs/libphp4.so
[activating module `php4' in /usr/local/apache/conf/httpd.conf]
cp libs/libphp4.so /usr/local/apache/libexec/libphp4.so
cp: libs/libphp4.so: A file or directory in the path name does not exist.
apxs:Break: Command failed with rc=1
make[1]: *** [install-sapi] Error 1
make[1]: Leaving directory `/oseda/php-4.2.3'
make: *** [install-recursive] Error 1
**************************************************

The directory "libs" has libphp4.a and libphp4.la only, the directory ".libs" has libphp4.a, .exp, .lai and .so.0 in it.
 [2002-11-26 04:57 UTC] sfrasca at deda dot com
I have a workaround about this bag.
I have installed php 4.2.3 under Oracle AS9i on AIX 4.3.3.
The libphp4.so not is created by make because the libtool have a flag set to no.
The libtool is created by configure; before you launch make, edit libtool and set build_libtool_libs=yes.
After launched make, under .libs you find libphp4.so.0:move it under libs as libphp4.so and run make install.
So, php as apache module work fine.
 [2003-02-25 00:43 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


It works now perfectly when using GCC.
Please test that it also works with the other CC too.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 04:01:55 2014 UTC