php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21714 Open_Basedir => errors
Submitted: 2003-01-17 13:53 UTC Modified: 2005-01-31 22:56 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: thibaud at phpnet dot org Assigned:
Status: Not a bug Package: Safe Mode/open_basedir
PHP Version: 4CVS-2003-01-17 (stable) OS: slackware linux
Private report: No CVE-ID: None
 [2003-01-17 13:53 UTC] thibaud at phpnet dot org
Hello,

I've ugrading from php 4.2.2 to php4-STABLE-200301171630.

Now, I've randomly this error on my php scripts:
<<<
Warning: Unknown(): open_basedir restriction in effect. File(/home/ovh/www/forum/list.php) is not within the allowed path(s): (/home/users/xiaoping) in Unknown on line 0

Warning: Unknown(/home/ovh/www/forum/list.php): failed to create stream: Operation not permitted in Unknown on line 0

Warning: (null)() [function.include]: Failed opening '/home/ovh/www/forum/list.php' for inclusion (include_path='.:/upload/') in Unknown on line 0 

>>>

I have add restrictions for the users with apache : php_admin_value open_base /path_users

This error is near the same with php 4.2.3.

Please HELP me, my serveur is : http://80.245.32.147/phpinfo.php

Cordialy

Thibaud GRANGIER
PHPNET

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-17 19:27 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Sep 26 09:01:24 2018 UTC