php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21713 include (URL) doesn't remove temporary files
Submitted: 2003-01-17 12:47 UTC Modified: 2003-02-22 04:42 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:3 (100.0%)
From: czuma at poland dot org Assigned: wez
Status: Closed Package: *Directory/Filesystem functions
PHP Version: 4.3.0 OS: Solaris 8
Private report: No CVE-ID:
 [2003-01-17 12:47 UTC] czuma at poland dot org
include("URL") doesn't remove temporary files in /var/tmp

PHP creates /var/tmp/php?????? files until...

ufs: [ID 682040 kern.notice] NOTICE: /var: out of inodes

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-17 19:27 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.
 [2003-01-17 19:29 UTC] wez@php.net
Let's keep this one open until I verify it; I have reason to believe that this is a valid problem.
 [2003-02-05 16:24 UTC] sfox at carleton dot edu
I've run into this as well since upgrading from 4.2.1 to 4.3 under Solaris 8/Apache.

It only happens when an include is processed that refers to a file that does NOT exist.  Every time this happens a file named php???? is left behind in /var/tmp using up a file handle.

2 errors are logged.  For example:

[error] PHP Warning:  main(left_menu.php) [<a href='h
ttp://www.php.net/function.main'>function.main</a>]: failed to create stream: No such file or directory in.......

[error] PHP Warning:  main() [<a href='http://www.php
.net/function.main'>function.main</a>]: Failed opening 'left_menu.php' for inclusion (include_path='.:/home/www/code') in......
 [2003-02-21 20:45 UTC] wez@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Please try the next stable snapshot.
 [2003-02-22 04:42 UTC] czuma at poland dot org
It works! Thank you.

I have tried php4-STABLE-200302220830 (PHP/4.3.2-dev)
 [2003-06-07 00:58 UTC] michael at comp1 dot gibbsdc dot com
Same problem occurs on UnixWare 7.1.3

Bug #24074  include(http://...) leaving files in /var/tmp
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 13:01:59 2014 UTC