php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2171 cgi is broken
Submitted: 1999-08-27 03:48 UTC Modified: 2000-04-02 00:13 UTC
From: w dot northcott at unsw dot edu dot au Assigned:
Status: Closed Package: Installation problem
PHP Version: 3.0.12 OS: Red Hat 6.0
Private report: No CVE-ID: None
 [1999-08-27 03:48 UTC] w dot northcott at unsw dot edu dot au
When PHP3 3.0.12 is compiled as a cgi it won't work.

When attempting to serve a .php3 file, php is invoked but instead of parsing the .php3 file, it tries to parse the executable!  It fails after a few hundred lines with a parsing error.

There are messages describing this problem with other versions of php3 and Apache on the mail list archive.  It seems not to have happened with php/FI

I tried various cgi compiles even turning off all security options which was mentioned in the mail list archive.  Nothing worked.  

When recompiled as an Apache module, it runs perfectly.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-04-02 00:13 UTC] rasmus at cvs dot php dot net
This is an installation problem on your end.  Please make sure your httpd.conf contains lines similar to:

            AddType  application/x-httpd-php3  .php3
            Action   application/x-httpd-php3  /cgi-bin/php

And that you have compiled your standalone binary using the --with-force-redirect flag.

Then put your php binary in your cgi-bin directory or any other ScriptAlias'ed directory in your document root and it should work just fine.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Oct 02 19:03:43 2022 UTC