php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21650 libphp4.so not found after a successful compile
Submitted: 2003-01-15 02:40 UTC Modified: 2003-01-20 15:48 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: tolga at kadikoy-bld dot gov dot tr Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.3.0 OS: AIX 4.3.3
Private report: No CVE-ID: None
 [2003-01-15 02:40 UTC] tolga at kadikoy-bld dot gov dot tr
config :  ./configure --with-apxs=/system/www/bin/apxs
gcc version : 2.9-aix43-010414 (yep,this is compiled by IBM for rs/6000 platform)

after a successful compiling phase following error message displayed...

---- cut here ----
Installing PHP SAPI module
[activating module `php4' in /system/www/conf/httpd.conf]
cp libs/libphp4.so /system/www/libexec/libphp4.so
cp: libs/libphp4.so: A file or directory in the path name does not exist.
apxs:Break: Command failed with rc=1
make: 1254-004 The error code from the last command is 1.


Stop.
----- cut here ----
there are libphp4.la and libphp4.a files in libs directory.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-19 22:38 UTC] sean dot foreman at ebenx dot com
I just hit this bug tonight. It appears this bug has been around in one form or another for over a year, but I haven't seen a solid solution yet. 

Basic bug: libphp4.la created instead of libphp4.so.

Closest solution so far:
The libphp4.so not is created by make because the libtool have a flag set to no. The libtool is created by configure; before you launch make, edit libtool and set build_libtool_libs=yes. After launched make, under .libs you find libphp4.so.0:move it under libs as libphp4.so and run make install.

This did not work for me (libphp4.so.0 file never created - .libs directory isn't created until make install...). Maybe it will work for you.

I will keep digging. If I find a solution, I will post it...

Research:

When I grep the Makefile for libphp4.so, I see:

libs/libphp4.bundle: $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
        $(CC) $(MH_BUNDLE_FLAGS) $(CFLAGS_CLEAN) $(EXTRA_CFLAGS) $(LDFLAGS) $(EXTRA_LDFLAGS) $(PHP_GLOBAL_OBJS:.lo=.o) $(PHP_SAPI_OB
JS:.lo=.o) $(PHP_FRAMEWORKS) $(EXTRA_LIBS) $(ZEND_EXTRA_LIBS) -o $@ && cp $@ libs/libphp4.so

This is a hint towards the solution...
 [2003-01-20 04:02 UTC] tolga at kadikoy-bld dot gov dot tr
build_libtool_libs already set to yes :)
 [2003-01-20 11:44 UTC] sean dot foreman at ebenx dot com
More info...

box: pentium 133
os: redhat 7.2

configure:
./configure --with-apsx2=/usr/local/apache/bin/apxs  --with-gettext --with-xml --with-mcrypt --with-imap --with-imap-ssl --with-mysql

I've tried these things with no success:
1. updating to the latest libtool (libtool-1.4d.tar.gz)
2. adjusting libtool parameters build_libtool_libs & build_old_libs
3. rerunning the last libtool command without -lcrypt
4. make libs/libphp4.bundle (creates libphp4.so, but it won't load when I restart apache).
5. updating to latest php snapshot (php4-STABLE-200301200430.tar.gz) and retrying steps 2, 3, 4

All of this, just to get mysql to work with php for imp preferences (www.horde.org/imp/)
 [2003-01-20 15:48 UTC] sniper@php.net
To tolga@kadikoy-bld.gov.tr:

  This bug is already reported here: 
    http://bugs.php.net/bug.php?id=14245

To sean.foreman@ebenx.com :

  Your problem has nothing to do with this bug.
  And you're not even close to the real solution..
  Please ask further _SUPPORT_ questions at the
  appropriate lists. (php-general/php-install)



 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 06:01:26 2020 UTC