php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21622 MSSQL: 100% CPU usage on database queries and eventually timeout
Submitted: 2003-01-13 13:16 UTC Modified: 2003-01-17 20:25 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: admin at bozobits dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.3.0 OS: Win2K
Private report: No CVE-ID: None
 [2003-01-13 13:16 UTC] admin at bozobits dot com
I installed php to utilize phpbb forums on a dual CPU high end server.  Win2K MSSQL 7.0.  Performance was ok but now having only 10,000 posts (and having moved to another server single P3 CPU) I cannot get anything to return from the database.  CPU pins at 100% until my forums eventually timeout.  All utilization is coming from MSSQL Server (cpu usage and memory).

I did have huge memory leak problems coming from MSSQL server on the first server (was using latest PHP installed around Oct/2002).  This seems to have gone away (PHP 4.3) but I can't tell for sure since I can't use the forums yet.

I have another set of forums on the same server (PHP/MSSQL) with only a few posts and they at least work.

I can query the database no problem outside of PHP with excellent performance.

I did search around in these bug reports and wasn't able to solve my problem.

Thank you.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-16 13:10 UTC] admin at bozobits dot com
This problem looks like it is solely related to the phpbb forum code.  I have isolated the problem there and submitted a bug report to them.

Performance is still overall sluggish and cpu intensive, but not a bug :)

Thanks!
BBJones
 [2003-01-17 20:25 UTC] sniper@php.net
Not PHP bug -> bogus. Thanks for reporting.

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 15:01:32 2024 UTC