php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21590 PHP 4.3.0 does not function
Submitted: 2003-01-11 16:51 UTC Modified: 2003-01-12 14:20 UTC
From: fischer at shoutingman dot com Assigned:
Status: Not a bug Package: PWS related
PHP Version: 4.3.0 OS: Windows 98 SE
Private report: No CVE-ID: None
 [2003-01-11 16:51 UTC] fischer at shoutingman dot com
I installed PHP 4.3.0 over 4.1.1 on a Win98SE machine running PWS. I installed using the installation program. After reinstall and reboot PHP scripts no longer functioned: the error was "Cannot find server" (and *not* the common server 500 error. it was the generic error for failing to even find a page.)

I verified the installation process: The installer failed to add the correction "extension_dir" path line in the php.ini file. Correcting that did not fix the problem.

I returned to the 4.1.1 version. It functions using either the php4ts.dll or the php.exe as the interpreter (set in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w3svc\parameters\Script Map registry key). It functions using either its php.ini file or the new one from the 4.3.0 installation.

The 4.3.0 system will not work, using either the php4ts.dll or php.exe as the interpreter set in the registry. The php.exe file works properly if called from the shell (to parse a php file). But it fails whenever called by way of PWS, it seems.

I have tried running the 4.3.0 installer twice, and I have manually installed 4.3.0 from the binaries. In all cases it fails. I can trivially reinstall 4.1.1 by replacing the 4.3.0 php.exe and php4ts.dll files with the 4.1.1 versions in my install directory.

I am using the default PHP configuration, with the exception of placing the install files in c:\program files\PHP.

I have not tried using the ISAPI dlls nor have I tried a different installation location.

I couldn't find this reported in the database.

Sincerely,

David Fischer
fischer@shoutingman.com

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-11 18:02 UTC] pollita@php.net
What extensions are you loading?

Did you copy the DLLs from the 4.3.0 installation package to your %SYSTEM%\ directory? (Note: the additional DLLs from your old 4.1.1 may not work with 4.3.0, hence copying the new DLLs)
 [2003-01-11 23:09 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.
 [2003-01-12 12:34 UTC] fischer at shoutingman dot com
I wanted to make sure I wasn't experiencing a quirk of my PWS installation, so I uninstalled PWS and removed every reference to PHP in the registry and in the windows directory I could.

I then reinstalled PWS. After verifying that PHP scripts did not run and were not recognized as any sort of script, I re-ran the PHP 4.3.0 installer. The result was the same: PHP files could not be executed as a web document, with the same error page.

Simply replacing the php.exe and php4ts.dll with the 4.1.1 versions restored functionality.
 [2003-01-12 12:39 UTC] fischer at shoutingman dot com
"What extensions are you loading?"
None

"Did you copy the DLLs from the 4.3.0 installation package to your %SYSTEM%\ directory?"
I tried that, but it didn't help. But from what I've read that seemed to be discouraged. Instead, the method is to use the registry key to "point" at the PHP binary.

In my second attempt, I merely let the installer do its thing.

I'll check the support sections. Perhaps not a problem with PHP per se, but it seems to be a problem with the Windows binaries and how they work with PWS on a Win98 system.

Thanks.
 [2003-01-12 14:20 UTC] fischer at shoutingman dot com
I've got 4.3.0 to function and I believe I know the problem: the " cgi.force_redirect=0" must be active in the php.ini file. This was not set by the installer.

It would likely save others time and frustration if the installer automatically set this. How could I submit this as a feature request for the installer people?

Thanks.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 13:03:48 2022 UTC