php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #21532 incorrect warning
Submitted: 2003-01-08 17:18 UTC Modified: 2015-02-20 15:12 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: czuma at poland dot org Assigned: krakjoe (profile)
Status: Closed Package: Safe Mode/open_basedir
PHP Version: 4.3.3 OS: Solaris 8
Private report: No CVE-ID: None
 [2003-01-08 17:18 UTC] czuma at poland dot org
PHP log:

-------------------------------------------------------
[08-Jan-2003 23:54:22] PHP Warning:  
opendir(): SAFE MODE Restriction in effect.  
The script whose uid is 405 is not allowed to access 
/www/user405/data/20021122 owned by uid 0 
in /www/user405/stale/table1a_stale_bpl.php on line 3

[08-Jan-2003 23:54:22] PHP Warning: 
opendir(/www/user405/data/20021122/bpl): 
failed to open dir: 
No such file or directory in 
/www/user405/stale/table1a_stale_bpl.php on line 3
-------------------------------------------------------

First warning is incorrect. Directory /www/user405/data/20021122 doesn't exist.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-01 12:07 UTC] czuma at poland dot org
I have checked php4-STABLE-200303011230

Unfortunately it doesn't work. I still see incorrect warning:

"SAFE MODE Restriction in effect. The script whose uid is XXX is not allowed to access /www/user/data owned by uid 0 in /www/user/stale/table1a.php on line 3"

"Line 3": 
$my=opendir("/www/user/data/$dat");

Probably: $dat=blabla/bleble.txt

Directory "blabla" doesn't exist. I see correct and then incorrect warning.
 [2003-10-30 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-11-01 14:17 UTC] czuma at poland dot org
I have tried php4-STABLE-200311011630.

Still I see the same error.
 [2010-12-29 17:50 UTC] jani@php.net
-Package: Feature/Change Request +Package: Safe Mode/open_basedir
 [2015-02-20 15:12 UTC] krakjoe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: krakjoe
 [2015-02-20 15:12 UTC] krakjoe@php.net
Since safe mode has been removed in modern version of PHP, we can put this to bed.

Sorry about the wait :)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jun 07 04:01:28 2020 UTC