php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21464 imap_get_quota broken in php4.3.0?
Submitted: 2003-01-06 10:10 UTC Modified: 2003-01-31 13:46 UTC
Votes:3
Avg. Score:4.7 ± 0.5
Reproduced:2 of 3 (66.7%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: bug at z4n dot de Assigned:
Status: No Feedback Package: IMAP related
PHP Version: 4.3.0 OS: UnitedLinux 1.0
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-01-06 10:10 UTC] bug at z4n dot de
just tried to get IMP3.1 running on UnitedLinux1.0

the IMP- configfile contains the "imap_get_quota" - command

however, when I disable the Line ("// ...") IMP works fine just without Quotadisplay

if i leave the Line active there comes no Output produced from any command after that Line

i use php 4.3.0/imap-2000a (without ssl)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-06 10:48 UTC] kalowsky@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


Marking as bogus, because the functionality of imap_get_quota was changed a bit to correct for a bug (which basically returned the wrong values).   You might want to try a newer IMP, or give a bit more information as to what is broken in the function.
 [2003-01-16 16:47 UTC] gkopp at ideastar dot com
I run into the same problem. I just compiled php 4.3.0 and I installed IMP 3.1. When IMP executes the command imap_get_quota or imap_get_quotaroot, the PHP processor barks:

Fatal error: Call to undefined function: imap_get_quota() in /usr/local/www/ideastar_mail/horde/imp/config/conf.php on line 391

I know IMAP is working, as the rest of IMP is working fine and the other imap commands work fine.
 [2003-01-17 00:53 UTC] kalowsky@php.net
have you spoken to the developers of IMP?  The parameters of the function haven't changed, only the output has to correct for a bug that returned the incorrect results for a quota (pretty regularly too).  There is some backward compatibility code added in to ease the transition, but since I'm not that familiar with IMP I can't comment on how it is using the code.  
 [2003-01-17 04:33 UTC] bug at z4n dot de
me again..
solved the problem temporarily by connecting to cyrus imapd using fsockopen and uning imap-commands (around 6 lines code)
i have the code on my computer at home, does someone like it?

the problem may be outside php
on a different server running SuSE 7.1/apache1.3.26
IMP run?s fine with the original imap_get_quota Syntax and php 4.3.0/imap-2000a (without ssl)
 [2003-01-17 09:13 UTC] kalowsky@php.net
Well the work around is a nice fix, and thats exactly how I confirmed that the function was working when I wrote it.  Tested on cyrus as well (it still does work for my test cases too).  

But that doesn't really help fix the bug (if there is one) in PHP.  Judging from the second paragraph though I'm going to assume this is a local configuration issue.  I'll leave this set to feedback for a while unless you find some new information... it will be closed in about 30 days.
 [2003-01-31 13:46 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 21:01:24 2020 UTC