php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21358 Pear install failes on NFS and many other networked file systems
Submitted: 2003-01-02 17:20 UTC Modified: 2004-09-01 16:36 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: fredrikr at ipfw dot edu Assigned: cox (profile)
Status: Not a bug Package: PEAR related
PHP Version: 4.3.0 OS: Linux
Private report: No CVE-ID: None
 [2003-01-02 17:20 UTC] fredrikr at ipfw dot edu
Make install with the related install-pear-* make directives will fail on NFS and many other networked file systems. 

Due to the use of flock() in php-4.3.0/pear/PEAR/Registry.php at line 282. 

A possable fix is to handle the block while locking on netword file systems via the use of the LOCK_NB operation.

See: http://www.php.net/manual/en/function.flock.php

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-03 19:00 UTC] pajoye@php.net
Someone to confirm that? Then to confirm the possible fix?
I do not have NFS system on any boxes here.

pierre
 [2003-08-18 11:26 UTC] fredrikr at ipfw dot edu
I did a test install with the latest stable version of PHP (PHP 4.3.2 (tar.bz2) [3,611Kb] - 29 May 2003). I am still experiencing the same problem with installing the PEAR files on a NFS mounted drive.

Make install with the related install-pear-* make directives will fail
on NFS and many other networked file systems. 

Due to the use of flock() in php-4.3.2/pear/PEAR/Registry.php at line
282. 

A possable fix is to handle the block while locking on netword file
systems via the use of the LOCK_NB operation.

See: http://www.php.net/manual/en/function.flock.php
 [2004-09-01 16:36 UTC] alan_k@php.net
can you report this on pear.php.net if the problem still exists - where the package maintainers now manage pear bugs


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 14:01:23 2020 UTC