php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21301 PHP_SELF is empty
Submitted: 2002-12-30 19:48 UTC Modified: 2003-02-18 23:40 UTC
From: tapken at engter dot de Assigned: shane (profile)
Status: Closed Package: Scripting Engine problem
PHP Version: 4.3.0 OS: Linux (SuSE)
Private report: No CVE-ID: None
 [2002-12-30 19:48 UTC] tapken at engter dot de
Did anyone change the way php get it's PHP_SELF-Variable?

On my server php-files are wrapped through a slightly patched version of
cgiwrap. I changed a few lines so that PHP_SELF is not broken and cgiwrap is not visible to the user. For details have a look at: http://www.engter.de/phpinfo.php
http://roland.engter.de/stuff/cgiwrap-PATH_INFO.patch
http://roland.engter.de/stuff/cgiwrap-SCRIPT_NAME.patch

With PHP 4.2.3 everything worked fine. But after updating to PHP 4.3.0 (with --disable-cli) PHP_SELF was empty. At first i thought that my
patch on cgiwrap was the reason for this, but finally i installed PHP 4.2.3 again and everything was fine.

Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-30 19:53 UTC] pollita@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

Please feel free to add your comments to Bug #21261.

In fact, please describe your operating environment as thoroughly as possible so that this bug can be reliably reproduced.

A dump of "/usr/local/apache/bin/httpd -l" and a list of all "LoadModule" lines would also be helpful.
 [2002-12-30 20:23 UTC] tapken at engter dot de
I'm not very sure if it is the same bug. In #21261 PATH_INFO is empty but as you can see on http://www.engter.de/shenv.php this is not the case in my installation.
 [2002-12-30 20:38 UTC] pollita@php.net
While the comments in that bug report get a little confusing, this *does* seem to be the same bug and indeed a problem in PHP and not the webserver as I thought at one point.
 [2002-12-31 02:15 UTC] derick@php.net
When we ask for feedback, we set the status to Feedback :)
 [2003-01-05 22:21 UTC] shane@php.net
I do beleive this is caused by the same problem that caused the bug 21261, please try the patch linked to on that bug.
 [2003-02-18 23:40 UTC] sniper@php.net
Assuming the fix for bug #21261 fixes this too..

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 22:03:39 2021 UTC