php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21276 cli and mssql charset pb
Submitted: 2002-12-29 17:54 UTC Modified: 2003-02-09 01:05 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: a dot benoit at alpi dot fr Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.3.0 OS: windows xp
Private report: No CVE-ID: None
 [2002-12-29 17:54 UTC] a dot benoit at alpi dot fr
This bug occurs with php-cli sapi and mssql module (under windows xp pro and with adodb lib):
if i can't use sql query like insert with accent(???#...etc) !

The same things work well with odbc module.

There is the same charset bug with stdout under winxp.

thanks

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-09 01:05 UTC] fmk@php.net
This is not a bug but a feature.

The Microsoft library (DBLIB) detects the context it is used in. Calling a php script using the cli version of PHP uses the default codepage for a DOS box (437 for US). If the same script is called from CGI or ISAPI it will use the Ansi codepage (1252 or whatever your system is configured for).

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jun 12 16:01:35 2024 UTC