php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21245 Windows Extensions can't load php_domxml.dll
Submitted: 2002-12-28 09:12 UTC Modified: 2003-01-08 17:03 UTC
From: itsuki at kali dot com dot cn Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: 4.3.0 OS: XP
Private report: No CVE-ID: None
 [2002-12-28 09:12 UTC] itsuki at kali dot com dot cn
can't load php_domxml.dll only! -_-

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-28 09:15 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2003-01-08 16:44 UTC] anne dot kootstra at hotpop dot com
loading the php_domxml.dll library supplied with the PHP 4.3.0 zip package is impossible. Activating the librabry in the php.ini file by removing out the ";" will result in the following "warning" alert popup:

"Unknown(): Unable to load dynamic library 'c:\php\ext\php_domxml.dll" - <translated> Can't find the ... module </translated> (OK button) and the following message on the loaded PHP page itself:

"Content-type: text/html X-Powered-By: PHP/4.3.0 
Fatal error: Call to undefined function: domxml_open_file() in c:\inetpub\wwwroot\build\aimledit\testxml.php on line 12
PHP Warning: Unknown(): Unable to load dynamic library 'c:\php\ext\php_domxml.dll' - Kan opgegeven module niet vinden. in Unknown on line 0 "

Hope this will help you track the problem.
 [2003-01-08 17:03 UTC] pollita@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

If you look at: http://www.php.net/manual/en/install.windows.php you'll notice that for some extensions to work under windows additional dlls must be copied to the correct location.

In your case libxml2.dll must be copied from the /extensions folder in your PHP distribution ZIP to your C:\WINDOWS\SYSTEM32 folder.


 [2003-01-10 14:34 UTC] anne dot kootstra at hotpop dot com
Yep, is indeed bogus.

Have put libxml2.dll version 2.4.30 for win32 in in /windows/system32/ folder and still get the same error message. 

Adding the same libxml2.dll in the windows/system/ also creates the exact same error. 

Even adding this libxml2.dll to the windows/php.ini as an extension creates the same error. 

The problem was that I started out with the windows installer version of PHP 4.3.0 and then just copied the libxml2 and php_domxml from the windows4.3.0.zip file to their locations. I completely forgot to copy the other DLL's from the php_install_dir/dlls/ folder to windows/system32. This solved the problem.

sorry for all this.
 [2003-01-10 14:34 UTC] anne dot kootstra at hotpop dot com
Yep, is indeed bogus.

Have put libxml2.dll version 2.4.30 for win32 in in /windows/system32/ folder and still get the same error message. 

Adding the same libxml2.dll in the windows/system/ also creates the exact same error. 

Even adding this libxml2.dll to the windows/php.ini as an extension creates the same error. 

The problem was that I started out with the windows installer version of PHP 4.3.0 and then just copied the libxml2 and php_domxml from the windows4.3.0.zip file to their locations. I completely forgot to copy the other DLL's from the php_install_dir/dlls/ folder to windows/system32. This solved the problem.

sorry for all this.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Nov 12 18:01:32 2019 UTC